Ask Your Question
3

problem with MoveIt/ rviz + joystick_control.launch

asked 2016-01-02 15:50:26 -0500

RockOn_23 gravatar image

I want to jog an industrial 6-axis robot in MoveIt/ rviz via a xbox 360 wireless controller.

I have created a MoveIt package as described here and started the demo.launch. Next, I installed MoveIt from source in the workspace and followed this instruction to start the joystick_control.launch.

Starting joystick_control.launch leads to

benjamin@benjamin:~/moveit$ roslaunch irb2400_moveit_cfg joystick_control.launch 
... logging to /home/benjamin/.ros/log/c348c3e0-b148-11e5-96a0-8c2937e5b4fe/roslaunch-benjamin-18627.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://benjamin:48251/

SUMMARY
========

PARAMETERS
 * /joy/autorepeat_rate: 40
 * /joy/coalesce_interval: 0.025
 * /joy/deadzone: 0.2
 * /joy/dev: /dev/input/js0
 * /rosdistro: indigo
 * /rosversion: 1.11.16

NODES
  /
    joy (joy/joy_node)
    moveit_joy (moveit_ros_visualization/moveit_joy.py)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[joy-1]: started with pid [18647]
process[moveit_joy-2]: started with pid [18653]
[ INFO] [1451737269.241626212]: Loading robot model 'abb_irb2400'...
[ INFO] [1451737270.145544577]: Loading robot model 'abb_irb2400'...
Traceback (most recent call last):
  File "/home/benjamin/moveit/src/moveit_ros/visualization/python/moveit_ros_visualization/moveit_joy.py", line 609, in <module>
    app = MoveitJoy()
  File "/home/benjamin/moveit/src/moveit_ros/visualization/python/moveit_ros_visualization/moveit_joy.py", line 380, in __init__
    self.updatePlanningGroup(0)
  File "/home/benjamin/moveit/src/moveit_ros/visualization/python/moveit_ros_visualization/moveit_joy.py", line 398, in updatePlanningGroup
    next_planning_group = self.planning_groups_keys[self.current_planning_group_index]
IndexError: list index out of range
terminate called after throwing an instance of 'class_loader::LibraryUnloadException'
  what():  Attempt to unload library that class_loader is unaware of.
[moveit_joy-2] process has died [pid 18653, exit code -6, cmd /home/benjamin/moveit/src/moveit_ros/visualization/python/moveit_ros_visualization/moveit_joy.py __name:=moveit_joy __log:=/home/benjamin/.ros/log/c348c3e0-b148-11e5-96a0-8c2937e5b4fe/moveit_joy-2.log].
log file: /home/benjamin/.ros/log/c348c3e0-b148-11e5-96a0-8c2937e5b4fe/moveit_joy-2*.log

this are the log files. I can't figure out the problem.

Can someone please help me?

edit retag flag offensive close merge delete

Comments

1

From a quick look this looks like a bug. Could you report this to ros-planning/moveit_ros/issues? Please also refer to this question in your issue.

gvdhoorn gravatar image gvdhoorn  ( 2016-01-03 05:25:20 -0500 )edit

Hi guys

I have the same problem but my move group is running properly. Could you give me some hints. Thank you for your time

Chickenman gravatar image Chickenman  ( 2016-04-14 15:41:15 -0500 )edit

I am also having this problem. When I run rqt_graph I can see that move_group is running and that joint_state_publisher is interacting with it, but joy is subscribed to nothing and is publishing nowhere

AustinWhitesell gravatar image AustinWhitesell  ( 2016-05-06 14:47:17 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-01-19 19:17:25 -0500

130s gravatar image

Most likely you're not running any movegroups yet. I had the same error, but after I roslaunched a launch that includes move_group.launch, this launch moved forward.

Indeed better error handling is necessary, but hope you can work around your immediate issue by this.

edit flag offensive delete link more

Comments

I had the same problem and made sure a movegroup was running and still have the same problem.

Airuno2L gravatar image Airuno2L  ( 2016-04-28 14:14:37 -0500 )edit

I have the same problem even when move_group.launch is running. Any suggestions?

danielsnider gravatar image danielsnider  ( 2017-02-09 20:26:41 -0500 )edit
1

If this is a still a problem, please report it at the MoveIt issue tracker so we can take a look at it.

gvdhoorn gravatar image gvdhoorn  ( 2017-02-10 00:24:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-02 15:50:26 -0500

Seen: 1,465 times

Last updated: Apr 14 '16