Ask Your Question
0

no window or output from rviz

asked 2015-12-17 12:11:28 -0500

Sam Bishop gravatar image

I've been running rviz (as well as the rest of the ROS stack) just fine on one computer, but now I can't get rviz to run on a second computer. Unfortunately, I don't get any output from rviz on the second computer, so I am having trouble figuring out how to debug it.

The second computer is pretty vanilla. (It's a 64-bit Intel PC running Ubuntu 14.04 and Indigo.) If I run rosrun rviz rviz after starting roscore, I get absolutely nothing. It just hangs, without output. (I've also checked my .ros/log files.) If I run without starting roscore, I get this

[ INFO] [1450375110.690702198]: rviz version 1.11.10
[ INFO] [1450375110.690762620]: compiled against OGRE version 1.8.1 (Byatis)

and a dialog box telling me that roscore isn't running.

I've tried the LIBGL_ALWAYS_SOFTWARE=1 environment-variable trick from the rviz troubleshooting page, and that didn't help.

The only relevant differences I can think of between the two computers is that the second computer has two monitors and an AMD video card, versus a single monitor and Intel integrated graphics. Any help would be appreciated.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-12-17 13:01:50 -0500

updated 2015-12-17 13:09:02 -0500

The differences you list are significant, and could certainly be responsible for your issues. Without more information, it is unlikely that anyone will be able to help. Things you could try to identify or workaround the issue:

  1. Try different drivers for your graphics card. In my own experiences, I've had terrible luck with AMD cards and Linux. I often run into issues with the drivers provided by fglrx or fglrx-updates, and the performance of the radeon drivers leaves something to be desired. The Ubuntu wiki has a pretty good tutorial on switching to various versions of the fglrx drivers. If you're already using fglrx you could revert to the radeon drivers.
  2. You could fallback to using your CPU's built-in graphics.
  3. Try disconnecting the second monitor. I have encountered issues in the past where multiple monitors cause issues. If this fixes the issue, it is possible that different settings in your Xorg.conf file would allow you to use both monitors with your ATI card.
  4. It seems odd that you would get no messages of any kind when you run rviz. If you can obtain some sort of error logs, backtraces, something, it would help people narrow down your errors. If you're really not getting anything in your terminal, you could try looking at dmesg for possible issues. There may be messages printed to /var/log/ files. You could try running rviz in gdb with a command like gdb -ex run /opt/ros/indigo/lib/rviz/rviz
edit flag offensive delete link more

Comments

Thank you! Using gdb I found that it was getting stuck loading the Oxygen theme for GTK, during the creation of the QApplication object.

Sam Bishop gravatar image Sam Bishop  ( 2015-12-17 14:32:28 -0500 )edit

That's great! So switching to a different theme resolved the issue?

jarvisschultz gravatar image jarvisschultz  ( 2015-12-17 17:13:04 -0500 )edit

I'm sorry, I should have made that clear. Yes, I uninstalled the theme and used the default. It's working now. Thanks again!

Sam Bishop gravatar image Sam Bishop  ( 2015-12-17 17:36:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-12-17 12:11:28 -0500

Seen: 575 times

Last updated: Dec 17 '15