ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

roscd: command not found

asked 2015-12-09 21:31:47 -0600

Reza1984 gravatar image


I faced this error: "roscd: command not found" same as rosnode except for roscore.

I have already setup my .bashrc by "source /opt/ros/jade/setup.bash"


edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-12-10 00:54:26 -0600

Akif gravatar image

Did you check these?;

Also you can check your environment variables.

edit flag offensive delete link more


Yes I have checked all the possible solutions in the net but none of them worked.

Reza1984 gravatar image Reza1984  ( 2015-12-10 02:38:47 -0600 )edit

Can you check printenv | grep ROS output?

Akif gravatar image Akif  ( 2015-12-10 06:03:18 -0600 )edit

Sorry for late reply. I have installed ROS again and it works now.

Reza1984 gravatar image Reza1984  ( 2016-03-03 01:29:22 -0600 )edit

Glad you solved it.

Akif gravatar image Akif  ( 2016-03-03 02:21:50 -0600 )edit

Question Tools

1 follower


Asked: 2015-12-09 21:31:47 -0600

Seen: 2,999 times

Last updated: Dec 10 '15