Missing ecto_image_pipeline

asked 2015-12-05 05:45:37 -0600

sykatch gravatar image

Hi, I am trying to do mesh_object but when I run

rosrun object_recognition_reconstruction mesh_object --all --visualize --commit

I get this:

     import ecto_image_pipeline.conversion
ImportError: No module named conversion

I found somewhere that I have to add the ecto_image_pipeline ros package to mylocal workspace and build the module by hand but I don't know how to do it. Can anyone help me please?

edit retag flag offensive close merge delete

Comments

i am facing the same problem. have you found any solution for this?

Asaad Irfan gravatar image Asaad Irfan  ( 2015-12-15 21:25:54 -0600 )edit

I think i didn't solve it, but I installed ORK again with ork.rosinstall and now I don't have this problem.

sykatch gravatar image sykatch  ( 2015-12-16 00:27:55 -0600 )edit
1

I just talked to a friend, he told me that it can be solved by cloning ecto_image_pipeline package from plasmodic repository on github into your ork workspace, than just do catkin_make and it should work. But I didn't try it yet.

sykatch gravatar image sykatch  ( 2015-12-17 06:44:09 -0600 )edit

I did almost the same thing: i cloned the ecto_image_pipeline from git and used catkin_make although the ork and ecto_image_pipleine folder sare different,but it works anyways.

Asaad Irfan gravatar image Asaad Irfan  ( 2015-12-17 07:04:39 -0600 )edit