Ask Your Question
0

Not able to install ROS on ubuntu 14.04.3

asked 2015-11-27 12:25:38 -0500

niksguru gravatar image

updated 2015-11-28 05:31:17 -0500

gvdhoorn gravatar image

I tried following the regular procedure but stuck at :-

sudo apt-get install xserver-xorg-dev-lts-utopic mesa-common-dev-lts-utopic libxatracker-dev-lts-utopic libopenvg1-mesa-dev-lts-utopic libgles2-mesa-dev-lts-utopic libgles1-mesa-dev-lts-utopic libgl1-mesa-dev-lts-utopic libgbm-dev-lts-utopic libegl1-mesa-dev-lts-utopic

The Error i am getting is :-

The following packages have unmet dependencies:
 libegl1-mesa-dev-lts-utopic : Depends: libegl1-mesa-lts-utopic (= 10.3.2-0ubuntu1~trusty2) but it is not going to be installed
                               Depends: libegl1-mesa-drivers-lts-utopic (= 10.3.2-0ubuntu1~trusty2) but it is not going to be installed
 libgbm-dev-lts-utopic : Depends: libgbm1-lts-utopic (= 10.3.2-0ubuntu1~trusty2) but it is not going to be installed
 libgl1-mesa-dev-lts-utopic : Depends: libgl1-mesa-glx-lts-utopic (= 10.3.2-0ubuntu1~trusty2) but it is not going to be installed
 libgles1-mesa-dev-lts-utopic : Depends: libgles1-mesa-lts-utopic (= 10.3.2-0ubuntu1~trusty2) but it is not going to be installed
 libgles2-mesa-dev-lts-utopic : Depends: libgles2-mesa-lts-utopic (= 10.3.2-0ubuntu1~trusty2) but it is not going to be installed
 libqt5feedback5 : Depends: libqt5multimedia5 (>= 5.0.2) but it is not going to be installed
 libqt5quick5 : Depends: libqt5gui5 (>= 5.2.0) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Please Help!!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-11-27 21:34:13 -0500

Willson Amalraj gravatar image

Your question needs a bit more explanation. Did you experience dependency issues while installing ROS?

The regular procedure is to skip sudo apt-get install xserver-xorg-dev-lts-utopic mesa-common-dev-lts-utopic libxatracker-dev-lts-utopic libopenvg1-mesa-dev-lts-utopic libgles2-mesa-dev-lts-utopic libgles1-mesa-dev-lts-utopic libgl1-mesa-dev-lts-utopic libgbm-dev-lts-utopic libegl1-mesa-dev-lts-utopic if you do not have dependency issues while ROS installation. There is a clear warning on the installation page which says "If you are using Ubuntu Trusty 14.04.2 and experience dependency issues during the ROS installation, you may have to install some additional system dependencies. Do not install these packages if you are using 14.04, it will destroy your X server "

After sudo apt-get update you can proceed to sudo apt-get install ros-xxx-desktop-full (replace xxx with indigo or jade depending on what distro you want to install) and if you have any dependency issues during this stage, you can go back to fixing the dependencies.

edit flag offensive delete link more

Comments

Make sure to read this section closely: http://wiki.ros.org/indigo/Installati...

tfoote gravatar image tfoote  ( 2016-05-08 14:45:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-27 12:25:38 -0500

Seen: 701 times

Last updated: Nov 28 '15