ROS Indigo Update leading to "instance of 'ros::serialization::StreamOverrunException'"

asked 2015-11-23 13:28:53 -0500

smudge gravatar image

I did an "apt-get update && apt-get upgrade" today, and it looked like it updated the Indigo packages (someone correct me if I am wrong in assuming an update was pushed recently).

In any case, after recompiling one of my packages with no changes having been made, my node keeps crashing throwing the following exception:

terminate called after throwing an instance of 'ros::serialization::StreamOverrunException'
  what():  Buffer Overrun

Is there a bug in the update? No changes were made on my end. How do I revert to the previous version of Indigo?

Thanks, Scott

edit retag flag offensive close merge delete

Comments

Have you tried a complete rebuild (ie: rm -rf devel/ build/, then catkin_make)? After a ROS update it's recommended to completely rebuild your workspace (especially with issues like the binary incompatibility in roscpp).

gvdhoorn gravatar imagegvdhoorn ( 2015-11-23 14:57:50 -0500 )edit

Yeah I tried that as well. I wound up just "apt-get remove"'ing indigo and then compiled it from source, which seemed to fix the problem. Strange, but thanks for the suggestion!

smudge gravatar imagesmudge ( 2015-11-24 08:39:47 -0500 )edit

You did a complete from-source install just for this issue? That should really not have been necessary. With a normal apt-get update && apt-get upgrade there might still be some pkgs not updated on your system. A dist-upgrade is recommended then (but take care: it updates other things as well).

gvdhoorn gravatar imagegvdhoorn ( 2015-11-24 12:19:35 -0500 )edit

Well it only took a few minutes to build from source. I tried a dist-upgrade as well, but to no success, though like you note, it upgraded my kernel and I had to rebuild some modules there as well.

smudge gravatar imagesmudge ( 2015-11-24 13:38:19 -0500 )edit

re: It only took a few minutes: sure, but it just seems like a work around, not a solution. The quoted error msg really seems to point to some ABI issue, which should either be located and diagnosed, or not have been introduced in the first place.

gvdhoorn gravatar imagegvdhoorn ( 2015-11-25 03:16:25 -0500 )edit