Ask Your Question
0

problem with running rgbdslamV2

asked 2015-11-23 04:43:44 -0600

fujisys gravatar image

My computer configuration: a quad-core CPU with 4GB of memory.

When I run rgbdslamV2, Memory usage reaches 100%。

How can I do to reduce memory usage? Or I must extend memory?

edit retag flag offensive close merge delete

Comments

I suppose rgdbslam is not very memory efficient. In my experiments I switched from 16 to 32 GB.

MichaelKorn gravatar imageMichaelKorn ( 2015-11-23 07:47:35 -0600 )edit

Thank you for your answer!

fujisys gravatar imagefujisys ( 2015-11-25 19:09:51 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-01-13 05:10:18 -0600

Hope it's not too late for some tuning advise. If you don't need the point cloud map increase the cloud_creation_skip_step to a higher power of two. If you do not have fast motions increase data_skip_step. You could also experiment with the options create_cloud_every_nth_node and store_pointclouds, but I suspect that they don't work anymore.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-11-23 04:43:44 -0600

Seen: 146 times

Last updated: Jan 13 '16