Ask Your Question
0

how to install ros indigo on Intel Edison

asked 2015-10-01 20:51:10 -0600

jbourne gravatar image

updated 2015-10-02 10:58:49 -0600

I am running through the tutorial http://wiki.ros.org/wiki/edison .

I get problems while downloading the package libconsole-bridge-dev (section 2.2 of http://wiki.ros.org/ROSberryPi/Instal... )

I first have to run

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 9165938D90FDDD2E

to get through "apt-get source -b console-bridge" command (this isn't listed in the tutorial)

and then when I run:

sudo dpkg -i libconsole-bridge0.2_*.deb libconsole-bridge-dev_*.deb

i get the error:

dpkg: error processing libconsole-bridge0.2_*.deb (--install):
 cannot access archive: No such file or directory
(Reading database ... 41269 files and directories currently installed.)
Preparing to replace libconsole-bridge-dev:i386 0.2.5-2.1 (using libconsole-bridge-dev_0.2.5-2.1_i386.deb) ...
Unpacking replacement libconsole-bridge-dev:i386 ...
dpkg: dependency problems prevent configuration of libconsole-bridge-dev:i386:
 libconsole-bridge-dev:i386 depends on libconsole-bridge0.2v5 (= 0.2.5-2.1); however:
  Package libconsole-bridge0.2v5 is not installed.

dpkg: error processing libconsole-bridge-dev:i386 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libconsole-bridge0.2_*.deb
 libconsole-bridge-dev:i386

I have no idea what I am doing wrong. I have completely started over by reflashing the intel edison (ubilinux) a couple of times now and still not being successful in installing ros indigo on the intel edison.

I would really appreciate any help on this matter

JB


also, when i run sudo apt-get -f install and uninstall libconsole-bridge-dev and then try to run:

sudo dpkg -i libconsole-bridge0.2_.deb libconsole-bridge-dev_.deb

I end up with this error message:

dpkg: error processing libconsole-bridge0.2_*.deb (--install):
 cannot access archive: No such file or directory
dpkg: error processing libconsole-bridge-dev_*.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 libconsole-bridge0.2_*.deb
 libconsole-bridge-dev_*.deb
edit retag flag offensive close merge delete

Comments

Please format console copy/pastes with the Preformatted text button, otherwise it can be rather hard to read. It's the one with 101010 on it.

gvdhoorn gravatar imagegvdhoorn ( 2015-10-02 05:12:26 -0600 )edit

I would repost your update as an answer, and then accept your own answer to mark your question as answered.

gvdhoorn gravatar imagegvdhoorn ( 2015-10-02 10:32:43 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-10-02 10:59:04 -0600

jbourne gravatar image

updated 2015-10-09 18:14:41 -0600

I ran these commands

cd ~/ros_catkin_ws/external_src
sudo apt-get install libboost-system-dev libboost-thread-dev
git clone https://github.com/ros/console_bridge.git
cd console_bridge
cmake .
sudo checkinstall make install

than ran sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/indigo finally got ros to install.

Note: the insctructions listed here didnt work for me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-10-01 20:38:43 -0600

Seen: 880 times

Last updated: Oct 09 '15