Ask Your Question
1

Corrupted ROS install on Debian Jessie after update

asked 2015-09-16 13:17:55 -0500

rbaleksandar gravatar image

updated 2015-09-16 15:18:51 -0500

Hi!

I'm trying to get my nodes to run on my Debian Jessie. I have developed those with Kubuntu 14.04. Both systems have the same ROS version - Indigo - however some libs are not the same. For example libopencv on Debian is 2.4.9 but on Ubuntu 14.04 it is 2.4.8. I have built and installed the Desktop version (rqt, rviz etc. included) on my Debian. It seems that something has gone really wrong. I can't run rviz due to

*** Error in `rviz': realloc(): invalid pointer: 0x00007f97b2fad860 ***
Aborted

My nodelet throws fatal erros at me:

[FATAL] [1442423922.398321597]: Service call failed!
[camera_nodelet_manager-2] process has died [pid 2652, exit code -11, cmd /opt/ros/indigo/lib/nodelet/nodelet manager __name:=camera_nodelet_manager __log:=/home/rosuser/.ros/log/f7737d60-5c96-11e5-b957-78dd08f4756e/camera_nodelet_manager-2.log].
log file: /home/rosuser/.ros/log/f7737d60-5c96-11e5-b957-78dd08f4756e/camera_nodelet_manager-2*.log
[camera/driver-3] process has died [pid 2653, exit code 255, cmd /opt/ros/indigo/lib/nodelet/nodelet load pmd_camboard_nano/driver /camera_nodelet_manager __name:=driver __log:=/home/rosuser/.ros/log/f7737d60-5c96-11e5-b957-78dd08f4756e/camera-driver-3.log].
log file: /home/rosuser/.ros/log/f7737d60-5c96-11e5-b957-78dd08f4756e/camera-driver-3*.log
[camera/rectify_depth-5] process has died [pid 2655, exit code 255, cmd /opt/ros/indigo/lib/nodelet/nodelet load image_proc/rectify /camera_nodelet_manager image_mono:=depth/image camera_info:=depth/camera_info image_rect:=depth/image_rect __name:=rectify_depth __log:=/home/rosuser/.ros/log/f7737d60-5c96-11e5-b957-78dd08f4756e/camera-rectify_depth-5.log].
log file: /home/rosuser/.ros/log/f7737d60-5c96-11e5-b957-78dd08f4756e/camera-rectify_depth-5*.log
[camera/rectify_amplitude-6] process has died [pid 2656, exit code 255, cmd /opt/ros/indigo/lib/nodelet/nodelet load image_proc/rectify /camera_nodelet_manager image_mono:=amplitude/image camera_info:=amplitude/camera_info image_rect:=amplitude/image_rect __name:=rectify_amplitude __log:=/home/rosuser/.ros/log/f7737d60-5c96-11e5-b957-78dd08f4756e/camera-rectify_amplitude-6.log].
log file: /home/rosuser/.ros/log/f7737d60-5c96-11e5-b957-78dd08f4756e/camera-rectify_amplitude-6*.log
[camera/rectify_distance-4] process has died [pid 2654, exit code 255, cmd /opt/ros/indigo/lib/nodelet/nodelet load image_proc/rectify /camera_nodelet_manager image_mono:=distance/image camera_info:=distance/camera_info image_rect:=distance/image_rect __name:=rectify_distance __log:=/home/rosuser/.ros/log/f7737d60-5c96-11e5-b957-78dd08f4756e/camera-rectify_distance-4.log].
log file: /home/rosuser/.ros/log/f7737d60-5c96-11e5-b957-78dd08f4756e/camera-rectify_distance-4*.log

This is followed by an endless restarting and starting of the separate processes involved and throwing the same errors over and over again.

All I have done in addition to my installation is to add to /usr/local my custom build of PCL and OpenCV (same versions as in upstream Debian Jessie but with some features enabled), which my no means interfere with the same libs but installed from upstream and in different locations. I have test with and without my custom installations - the result is the same. The update here refers to the building and installation of a bunch of additional packages (that I require or might require at some point in the future) among which is the image_pipeline set, tf, nodelet set etc. None gave any indication of being broken during the building process and the following installation. Also it seems to be impossible to use custom OpenCV install because no matter what I do (tried checkinstall and tested the installation with multiple different names for this library ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-09-21 19:30:24 -0500

rbaleksandar gravatar image

Fixed it by doing a clean build with ONLY my custom built OpenCV and PCL inside my catkin workspace and then installing the packages.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-09-16 13:17:55 -0500

Seen: 297 times

Last updated: Sep 21 '15