installed build-essential but still get CXX compiler not found error

asked 2015-08-25 13:14:18 -0600

ham2010 gravatar image

updated 2015-08-26 01:05:24 -0600

gvdhoorn gravatar image

I am having the same problem I've seen from multiple posts from 2012 about CXX compiler not being found. I did run sudo apt-get install build-essential checkinstall and still get the following when I run cmake:

-- The CXX compiler identification is unknown
-- Check for working CXX compiler: /usr/local/bin/cl
CMake Error: your CXX compiler: "/usr/local/bin/cl" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.

Where do I look for what is causing it to try to find "cl"?

edit retag flag offensive close merge delete

Comments

1

Please add some more information: what platform is this, what OS, version of OS, version of ROS, how did you install it (from source, or debs), etc.

Also: why do you invoke cmake directly? Normal build steps for ROS pkgs do not include the user invoking cmake directly, which is why I ask.

gvdhoorn gravatar imagegvdhoorn ( 2015-08-26 01:06:40 -0600 )edit