lsd_slam visualization problem

asked 2015-07-13 01:03:54 -0600

jossy gravatar image

updated 2015-07-13 01:36:05 -0600

I installed ubuntu 14.04 and ros-indigo. I run lsd_slam succesfully. Due to some problem, I uninstall ros.

I installed ros from here. I just reinstall ros-indigo. But I can't run lsd_slam on this platform. There is a section named quick start in lsd_slam readme file. This section shows that how to run a lsd_slam example using .bag file. It says that :

Launch the lsd_slam viewer:

    rosrun lsd_slam_viewer viewer

 Launch the lsd_slam main ros node:

    rosrun lsd_slam_core live_slam image:=/image_raw camera_info:=/camera_info

Play the sequence:

    rosbag play ~/LSD_room.bag

 You should see one window showing the current keyframe with color-coded depth (from live_slam), 
and one window showing the 3D map (from viewer).

I run these commands different terminal. I don't see color-coded depth. My screenshot is below :

image description

What is th eproblem? How can I run this example properly?


There are files and folders under lsd_slam/build after I run rosmake lsd_slam. This means that Do I use catkin workspace? lf yes, how can I remove catkin because lsd_slam doesn't use catkin?

edit retag flag offensive close merge delete


I am also geting this same problem did you found any solution?

Azharudeen gravatar image Azharudeen  ( 2016-02-10 08:24:52 -0600 )edit

Hi, don't you see anything in the viewer window even when you do some translation? You will see the color coded depth in a window which is opened by live_slam and the 3d map in the viewer. If you want, you can use catkinized lsd_slam from

ank700 gravatar image ank700  ( 2016-05-18 08:09:21 -0600 )edit