roslaunch not working

asked 2015-07-01 14:36:50 -0600

saikrishnagv gravatar image

updated 2015-07-02 02:46:39 -0600

gvdhoorn gravatar image

http://wiki.ros.org/rosbag/Tutorials/... I am following this tutorial to export images from a bag file. in src in catkin workspace, I created a new package myimage. created a folder launch, and copy-pasted export.launch in that folder. I then, did roslaunch export.launch

and I got the error message:

Unable to contact my own server at [http://192.168.1.4:43535/].
This usually means that the network is not configured properly.

A common cause is that the machine cannot ping itself.  Please check
for errors by running:

    ping 192.168.1.4

For more tips, please see

    http://www.ros.org/wiki/ROS/NetworkSetup

I have tried this: http://answers.ros.org/question/10238... but, it did not help in my case. It is still showing the same error

edit retag flag offensive close merge delete

Comments

1

It seems you are only trying to run nodes on your computer. Likely, the most reliable setup will be to have ROS_HOSTNAME and ROS_IP unset, and to have ROS_MASTER_URI set to http://localhost:11311/

jarvisschultz gravatar image jarvisschultz  ( 2015-07-01 15:09:04 -0600 )edit

Try running unset ROS_HOSTNAME && unset ROS_IP && export ROS_MASTER_URI=http://localhost:11311/ and then try running your launch file in the same terminal.

jarvisschultz gravatar image jarvisschultz  ( 2015-07-01 15:10:01 -0600 )edit