Ask Your Question
0

I have a problem while installing ROS with Eclispe

asked 2015-06-12 03:49:18 -0500

Ravi Dhoble gravatar image

First of all please update the ROS IDE webpage..i think there is problem with the information given for the installation of ROS with Eclispe IDE.. I am using ROS Indigo version. I started with the normal procedure given on ROS IDE webpge but the instruction given on the page from line-->

Open a terminal, roscd into the folder of your package, and execute:

make eclipse-project as i had executed the instruction for rosbuild approach i got an error --> make: * No rule to make target `eclispe-project'. Stop. I searched for this error and found it on ROS answer. I followed the instructions but couldn't worked. I have also tried the catkin-y method but i also got the error while following the further related instructions. I am new to the ROS and am learning it with an interest and passion and i found this is awesome for buildind robots applications. Please kindly provide the solution how can integrate ROS with Eclispe because i want write my own packages for the ROS.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-06-12 10:45:47 -0500

Dben gravatar image

First, be sure to have the CDT edition and don't do it in your ROS workspace. The best is to have you ROS ws and Eclipse ws folders in the same folder Precise your source folder and use this:

catkin_make --force-cmake -G"Eclipse CDT4 - Unix Makefiles" --source $source_folder -DCMAKE_BUILD_TYPE=Debug

You also can add this argument, depending on your version and how powerful your computer is

-DCMAKE_ECLIPSE_MAKE_ARGUMENTS=-j2
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-12 03:46:17 -0500

Seen: 110 times

Last updated: Jun 12 '15