ROS Indigo in Eclipse Luna IDE problem

asked 2015-05-23 10:33:21 -0500

Diego gravatar image

Hello guys, I have a problem when importing my ROS project to Eclipse. In my project I import packages from OpenCV and 2 more packages from NAO choreographe (actionlib and naoqi_msgs) program exported to work with C++. I am using catkin build, I also tried with catkin make and the same mistake appears, so I think that something is missing in what I have to do and I would like you guys to help me telling what else is missing

I am following this tutorial .

For my first trial I followed this path:

I. (2.3) catkin tools (I tried with and without the 3rd command in order to use debug) II. (3.1) Fixing unresolved includes (I tried points 3,4,5... First one I didn't do cause this is a new project I'm creating. For point 2 I didn't know where and how to load the .bashrc environment into my eclipse) III. (4) Building the project inside Eclipse, I looked for the 4 environment variables and they were correctly located)

For my second trial I did the same, but this time with catkin_make so (2.2), (3.1), (4)

Since I tried like 3 or 4 times thinking that I was wrong, then I am assuming that my mistake is because I didn't modify the .bashrc (I didn't know where it is) but if there is something different, I would be very thankful if you guys could tell me the reason.

Thanks for your help. I think it's not necessary, however I am adding the image of the result in my IDE. the errors that appear say Unresolved Inclusion: <package> image description

edit retag flag offensive close merge delete