Ask Your Question
0

change rviz log level

asked 2015-05-01 21:28:59 -0500

gustavogoretkin gravatar image

in rqt_logger_level, I see an rviz node, but there are no loggers within. Ideally I'm looking for a command-line switch that makes rviz spit out debug messages to the console.

I also tried adding the line log4j.logger.ros.rviz=DEBUG to the file pointed to by ROSCONSOLE_CONFIG_FILE, which has worked for nodes I launch, but not for rviz.

edit retag flag offensive close merge delete

Comments

1

I think the issue is that rviz starts as an "anonymous" node, meaning it doesn't name collide with other "rviz" nodes. This is accomplished by changing the node name to rviz_<random hexidecimal numbers>. Open an issue against rviz, it might be possible to add an option to rviz to make it happen.

William gravatar imageWilliam ( 2015-05-03 18:52:08 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-05-04 15:20:20 -0500

ahendrix gravatar image

Not a full solution, but it should be possible to change the logger level at runtime with rqt_logger_level, but you won't be able to see debug messages at startup.

You may also want to try starting rviz with __name:=rviz to try to force it to use a non-anonymous name, which might make it pick up the proper logger configuration.

If you're developing plugins and you only want to see debug messages from your plugin, you can also use the ROS_DEBUG_NAMED() with your plugin name.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-01 21:28:59 -0500

Seen: 310 times

Last updated: May 04 '15