Ask Your Question
0

Trouble with building 'rviz' in hydro [Possible cause shiboken]

asked 2015-04-03 09:18:03 -0500

adi93 gravatar image

updated 2015-04-05 06:15:03 -0500

Hi there!

I am new to ROS community and currently building hydro from source on ubuntu 12.04. I have been following the wiki and am having trouble with building rviz package. I am on this step:

user@ubuntu12.04:~/ros_catkin_ws/$./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release

Until now, my errors were mainly due to the absence of some C++ header files, but in this case, I am not sure what the error is. Here is my log:

-- Found PythonInterp: /usr/bin/python (found version "2.7.3")
-- Using PYTHON_EXECUTABLE: /usr/bin/python
-- Python version: 2.7
-- Using Debian Python package layout
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/ros/ros_catkin_ws/build_isolated/rviz/test_results
-- Found gtest: gtests will be built
-- catkin 0.5.90
-- Using these message generators: gencpp;genlisp;genpy
-- Eigen found (include: /usr/include/eigen3)
making version 1.10.19.
-- checking for module 'assimp'
--   found assimp, version 2.0
-- Assimp version does not have unified headers
-- checking for module 'yaml-cpp>=0.5'
--   package 'yaml-cpp>=0.5' not found
TODO: convert rviz tests to catkin.
-- libshiboken built for Release
Using SHIBOKEN_LIBRARY: /usr/lib/x86_64-linux-gnu/libshiboken-python2.7.so
-- Using default python: -python2.7
Using PYSIDE_LIBRARY: /usr/lib/x86_64-linux-gnu/libpyside-python2.7.so
-- Found PythonLibs: /usr/lib/libpython2.7.so (Required is at least version "2.7")
-- Shiboken binding generator available.
-- Found PythonInterp: /usr/bin/python (found suitable version "2.7.3", required is "2.7")
-- SIP binding generator available.
Python binding generators: shiboken;sip
-- Configuring incomplete, errors occurred!
user@ubuntu12.04:~/ros_catkin_ws/$

I tried removing the shiboken as suggested, but then it showed an error of "Shiboken binding generator NOT available." Can anyone point out what I am missing? Or just point me to the right page? Tell me if you require some other info:)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-04-05 14:22:03 -0500

ahendrix gravatar image

This doesn't look like a problem with shiboken.

It looks like it's failing to find yaml-cpp:

--   package 'yaml-cpp>=0.5' not found

Have you tried using rosdep to install the required dependencies?

rosdep install --from-paths src -i -y
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-03 09:18:03 -0500

Seen: 126 times

Last updated: Apr 05 '15