Ask Your Question
0

NVIDIA Jetson TK1 Board and rviz indigo

asked 2015-04-01 02:41:18 -0500

ctubio gravatar image

Hi

Has Anyone tested rviz in NVIDIA Jetson Board?

We are looking the most lightweight and compact hardware that allows run rviz in a properly way.

We have focused in this hardware, which has a NVIDIA GPU, because I have read threads here that it suggests the use of NVIDIA GPU to avoid problems with rviz.

Best regard.

edit retag flag offensive close merge delete

Comments

Did you solve the issue I am having the same problem? Seg Fault

jaghvi gravatar image jaghvi  ( 2015-05-22 13:09:57 -0500 )edit

Hi jaghvi,

In fact we don´t have the board. We were waiting any user experience about this one.

I see that you have some problems. If you fix the problem please let me know.

Best regards

ctubio gravatar image ctubio  ( 2015-05-25 08:38:14 -0500 )edit

@jaghvi: if you need help, please ask a new question instead of posting an answer.

ahendrix gravatar image ahendrix  ( 2015-05-25 23:11:49 -0500 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2015-06-02 12:40:06 -0500

esteve gravatar image

We've got rviz running on a Jetson TK1, but found issues with the version of libpcre (which libogre depends on) that Ubuntu Trusty ships with. We ended up installing libpcre 1:8.35 from Utopic.

edit flag offensive delete link more
1

answered 2015-06-02 08:20:18 -0500

I did not explicitly required rviz on Jetson, I mitigated the problem by running rviz on my laptop and communicated between my laptop and jetson over ethernet/internet. That is, Jetson acts as a master computer which runs ROS and you can connect as many computers you want over the same network and all the nodes will be talking to each other.

edit flag offensive delete link more
0

answered 2015-09-28 01:09:55 -0500

vishu2287 gravatar image

rviz segmentaiton fault in jetson board,

I have solved it by following these steps

$ sudo apt-get remove ros-indigo-robot-model $ cd ~/catkin_ws/src $ git clone https://github.com/ros/robot_model.git $ cd ~/catkin_ws $ catkin_make $ source devel/setup.bash

Its working fine..

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-04-01 02:41:18 -0500

Seen: 682 times

Last updated: Sep 28 '15