ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

cmake error, poco was not found, Raspberry Pi, ROS Indigo

asked 2015-03-09 05:53:40 -0500

Ben12345 gravatar image

Hi all,

I'm new to ROS and having trouble trying to install everything on an RPI.

I'm following this link here -

I'm up to 2.3 Building the catkin Workspace, and when running the command "sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/indigo" I get the following error:

CMake Error at /opt/ros/indigo/share/cmake_modules/cmake/Modules/FindPoco.cmake:186

Messgae reads: Poco was not found. Set the Poco_INCLUDE_DIR cmake cache entry to the top-level directories. E.g /usr/local/include or c:\poco\include\poco-1.3.2

I don't want to start messing about with obscure files looking for something as it's taken several days to get to this point and i don't want to start over if i can avoid it. Any help would be greatly appreciated.


edit retag flag offensive close merge delete


I get the same error on my Pi, Did you perhaps figure it out?

miguel gravatar image miguel  ( 2015-06-27 05:08:04 -0500 )edit

Hi, no sorry i didn't. I used beagle bone black instead. Moved on to using an intel based fanless computer running full desktop ubuntu. Makes life a lot easier. I have got a a raspberry pi 2 now, will try again. You can run the arm ubuntu on the new pi, ROS jade has arm ubuntu, should be all current

Ben12345 gravatar image Ben12345  ( 2015-06-28 14:52:48 -0500 )edit

commenting system has a character limit - i think the issue was the raspberry pi distro changing so much. The new jade ROS came out a few weeks ago, ARM ubuntu is not run by the pi foundation so should be more stable for want of a better word. it's also a proper OS, not a hacked one.

Ben12345 gravatar image Ben12345  ( 2015-06-28 14:54:19 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2015-11-13 13:47:52 -0500

ATXCyborg gravatar image

We had a similar issue while setting up an rPi 2 on wheezy. The solution that worked for us was to download the poco c++ library from POCO C++ Project and follow the instructions listed here. The instructions seem very detailed for various systems but we only verified it worked on the linux system for rPi. This solved our issues regarding POCO.

edit flag offensive delete link more

answered 2016-09-27 19:01:42 -0500

mtbrobotanist gravatar image

updated 2016-09-27 19:03:03 -0500

sudo apt-get install libpoco-dev

edit flag offensive delete link more

Question Tools


Asked: 2015-03-09 05:53:40 -0500

Seen: 6,475 times

Last updated: Sep 27 '16