Ask Your Question
1

Error when building ros packages on MAC OS X Yosemite

asked 2015-03-05 15:12:24 -0500

heyikan gravatar image

updated 2015-03-06 13:38:07 -0500

William gravatar image

Hi all,

I'm trying to install ROS-indigo on Mac OS X Yosemite but i will be damned soon :) . I created a workspace and following code worked properly.

$ rosinstall_generator desktop_full --rosdistro indigo --deps --wet-only --tar > indigo-desktop-full-wet.rosinstall
$ wstool init -j8 src indigo-desktop-full-wet.rosinstall

but;

$ rosdep install --from-paths src --ignore-src --rosdistro indigo -y

this code produces an error:

executing command [brew install opencv]
Warning: opencv-2.4.10.1 already installed, it's just not linked
ERROR: the following rosdeps failed to install
  homebrew: Failed to detect successful installation of [opencv]

I skip this error and I tried to build src files by using:

./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release

The problem is: First 8 packaged built completely but 9. package ( class_loader ) produce error:

-- catkin 0.6.11
CMake Error at CMakeLists.txt:6 (find_package):
  By not providing "Findconsole_bridge.cmake" in CMAKE_MODULE_PATH this
  project has asked CMake to find a package configuration file provided by
  "console_bridge", but CMake did not find one.

  Could not find a package configuration file provided by "console_bridge"
  with any of the following names:

    console_bridgeConfig.cmake
    console_bridge-config.cmake

  Add the installation prefix of "console_bridge" to CMAKE_PREFIX_PATH or set
  "console_bridge_DIR" to a directory containing one of the above files.  If
  "console_bridge" provides a separate development package or SDK, be sure it
  has been installed.


    -- Configuring incomplete, errors occurred!
    See also "/Users/Hakan/ros_catkin_ws/build_isolated/class_loader/CMakeFiles/CMakeOutput.log".
    <== Failed to process package 'class_loader': 
      Command '/Users/Hakan/ros_catkin_ws/install_isolated/env.sh cmake /Users/Hakan/ros_catkin_ws/src/class_loader -DCATKIN_DEVEL_PREFIX=/Users/Hakan/ros_catkin_ws/devel_isolated/class_loader -DCMAKE_INSTALL_PREFIX=/Users/Hakan/ros_catkin_ws/install_isolated -DCMAKE_BUILD_TYPE=Release -G Unix Makefiles' returned non-zero exit status 1

    Reproduce this error by running:
    ==> cd /Users/Hakan/ros_catkin_ws/build_isolated/class_loader && /Users/Hakan/ros_catkin_ws/install_isolated/env.sh cmake /Users/Hakan/ros_catkin_ws/src/class_loader -DCATKIN_DEVEL_PREFIX=/Users/Hakan/ros_catkin_ws/devel_isolated/class_loader -DCMAKE_INSTALL_PREFIX=/Users/Hakan/ros_catkin_ws/install_isolated -DCMAKE_BUILD_TYPE=Release -G Unix Makefiles

    Command failed, exiting.

I googling for a long time but i couldn't find any solution.

any suggestion ??

Thanks...

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-03-06 13:36:24 -0500

William gravatar image

I skip this error and I tried to build src files by using:

You need to continue past that error. Use something like:

rosdep install --from-paths src --ignore-src --rosdistro indigo -y --skip-keys libopencv-dev

To skip the check on opencv, but continue installing other dependencies.

Or you could actually resolve the issue with opencv, it pretty clearly states that you've installed opencv from Homebrew already but it has not been linked. (see: https://github.com/Homebrew/homebrew/... )

The error about not finding console_bridgeConfig.cmake is because you didn't let rosdep install all of the dependencies (like console_bridge).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-03-05 15:11:13 -0500

Seen: 4,144 times

Last updated: Mar 06 '15