Ask Your Question
1

No devices connected

asked 2015-02-10 07:37:30 -0500

Elizaveta.Elagina gravatar image

updated 2015-02-26 01:35:10 -0500

Hello! I'm trying to connect my laptop to Kinect. After running roslaunch openni_launch openni.launch I get the following message: No devices connected.... waiting for devices to be connected. I know this question has been asked many times, but I've tried all of the advice I found here and am running out of ideas. When I run killall XnSensorServer I get no such process found and when I run XnSensorServer I get XnSensorServer: error while loading shared libraries: libOpenNI.so: wrong ELF class: ELFCLASS64. Could this be the issue? How can I fix it?

Best regards, Elizaveta

UPD

turtle@turtle-brain:~$ apt-cache policy libopenni0
libopenni0:
  Установлен: 1.5.4.0-7
  Кандидат:   1.5.4.0-7
  Таблица версий:
 *** 1.5.4.0-7 0
        500 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status
turtle@turtle-brain:~$ ldd /usr/lib/libopenni-sensor-primesense0/XnSensorServer
    linux-vdso.so.1 =>  (0x00007fff519eb000)
    libOpenNI.so.0 => /usr/lib/libOpenNI.so.0 (0x00007fde9cba8000)
    libXnFormats.so.0 => /usr/lib/libXnFormats.so.0 (0x00007fde9c981000)
    libXnDDK.so.0 => /usr/lib/libXnDDK.so.0 (0x00007fde9c729000)
    libXnDeviceSensorV2.so.0 => /usr/lib/libXnDeviceSensorV2.so.0 (0x00007fde9c484000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fde9c0bd000)
    libusb-1.0.so.0 => /lib/x86_64-linux-gnu/libusb-1.0.so.0 (0x00007fde9bea6000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fde9bca2000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fde9ba83000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fde9b87b000)
    libtinyxml.so.2.6.2 => /usr/lib/x86_64-linux-gnu/libtinyxml.so.2.6.2 (0x00007fde9b666000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fde9b361000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fde9b05b000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fde9ae45000)
    /lib64/ld-linux-x86-64.so.2 (0x00007fde9ce51000)
    libXnCore.so.0 => /usr/lib/libXnCore.so.0 (0x00007fde9ac40000)
    libjpeg.so.8 => /usr/lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007fde9a9eb000)
    libudev.so.1 => /lib/x86_64-linux-gnu/libudev.so.1 (0x00007fde9a7d9000)
    libcgmanager.so.0 => /lib/x86_64-linux-gnu/libcgmanager.so.0 (0x00007fde9a5be000)
    libnih.so.1 => /lib/x86_64-linux-gnu/libnih.so.1 (0x00007fde9a3a5000)
    libnih-dbus.so.1 => /lib/x86_64-linux-gnu/libnih-dbus.so.1 (0x00007fde9a19b000)
    libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007fde99f56000)
turtle@turtle-brain:~$ uname -a
Linux turtle-brain 3.13.0-43-generic #72-Ubuntu SMP Mon Dec 8 19:35:06 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

I am using Ubuntu 14.04 and ROS Indigo.

When I run dpkg-query --list |grep openni |awk '{print $2}' | xargs -d "\n" sudo apt-get install --reinstall -y I get the following:

turtle@turtle-brain:~$ dpkg-query --list |grep openni |awk '{print $2}' | xargs -d "\n" sudo apt-get install --reinstall -y 
Чтение списков пакетов… Готово (reading package lists - ready)
Построение дерева зависимостей (building dependency trees) Чтение информации о состоянии… Готово (reading state information -ready) Некоторые пакеты невозможно установить. (Some packages can't be installed)
Возможно, вы просите невозможного, или же используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. (Maybe you request the impossible or use an unstable distributive version where the requested packages aren't installed or were deleted)
Следующая информация, возможно, поможет вам: (Following information might ...
(more)
edit retag flag offensive close merge delete

Comments

2

The error about ELF class could certainly be contributing to your problem. It looks like you have a 64 bit version of libOpenNI.so, but your computer is a 32 bit machine. Did you install the libopenni0 package from apt-get? If so, it could be that your sources are setup wrong.

jarvisschultz gravatar imagejarvisschultz ( 2015-02-10 09:36:04 -0500 )edit
1

Please edit your question and add the output of apt-cache policy libopenni0 and ldd /usr/lib/libopenni-sensor-primesense0/XnSensorServer and uname -a

jarvisschultz gravatar imagejarvisschultz ( 2015-02-10 09:38:36 -0500 )edit

I guess I have installed it from apt-get. If this is the problem, how do I change my sources setup? Thanks in advance!

Elizaveta.Elagina gravatar imageElizaveta.Elagina ( 2015-02-12 03:25:27 -0500 )edit

Interestingly, the output of uname -a suggests you have a 64-bit machine, and your apt-cache policy command suggests that your sources are setup correctly. Let's try re-installing all of your openni packages from apt-get in case you've accidently installed some conflicting files without apt-get

jarvisschultz gravatar imagejarvisschultz ( 2015-02-17 08:31:08 -0500 )edit

I just used the following command to accomplish this reinstall dpkg-query --list |grep openni |awk '{print $2}' | xargs -d "\n" sudo apt-get install --reinstall -y

jarvisschultz gravatar imagejarvisschultz ( 2015-02-17 08:31:31 -0500 )edit

As another option, you could try using freenect_launch to run your Kinect instead of openni_launch

jarvisschultz gravatar imagejarvisschultz ( 2015-02-17 08:33:18 -0500 )edit

Those errors would be better presented by editing your original question. You have some conflicting packages; this could mean that you have installed openni packages from multiple places. You could also be running into issues that are documented: https://github.com/turtlebot/turtlebo...

jarvisschultz gravatar imagejarvisschultz ( 2015-02-23 18:38:34 -0500 )edit

When I run into package conflicts, I often turn towards aptitude instead of apt-get it is better at presenting solutions to these types of conflicts. Did you ever try freenect_launch?

jarvisschultz gravatar imagejarvisschultz ( 2015-02-23 18:39:20 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2015-03-02 14:33:31 -0500

Mark Silliman gravatar image

For anyone else that has this issue...

Go to: http://learn.turtlebot.com/2015/02/01/8/

Scroll down to "Troubleshooting". From there make sure you following the instructions on:

  1. Installing the driver
  2. Disable USB 3.0 via the BIOS (a little farther down the page)

This will fix most of the problems related to Kinect not working.

edit flag offensive delete link more

Comments

She definitely has package conflicts, and errors related to system architecture. The posted resource is excellent, but I'd be surprised if disabling USB 3.0 would fix any issues.

jarvisschultz gravatar imagejarvisschultz ( 2015-03-04 11:10:42 -0500 )edit
1

Thanks Jarvis. We had a newer laptop with the identical error msg. BIOS fixed it because the Kinect is incompatible with most 3.0 USBs as well as many newer 2.0 USBs which are compatible with 3.0. The trick that the BIOS does is it effectively downgrades them all so the Kinect can work.

Mark Silliman gravatar imageMark Silliman ( 2015-03-05 11:47:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-02-10 07:37:30 -0500

Seen: 1,447 times

Last updated: Mar 02 '15