Ask Your Question
0

[Beginner] About running a package like a node

asked 2015-02-04 02:14:19 -0500

pexison gravatar image

Hi i am stuck because of this, yesterday i ran the HelloWC (not following the name for files convention) and it works, today i try to recompile it and run.... but this is the ouput:

####
#### Running command: "make cmake_check_build_system" in "/home/robot/Desktop/package_2/build"
####
####
#### Running command: "make -j4 -l4" in "/home/robot/Desktop/package_2/build"
####
[ 50%] Built target HelloWC
[100%] Built target HelloWC_node
robot@ASHROCK:~/Desktop/package_2$ rosrun HelloWC HelloWC_node
[rospack] Error: stack/package HelloWC not found
[rosrun] Couldn't find executable named HelloWC_node below 
[rosrun] Found the following, but they're either not files,
[rosrun] or not executable:
[rosrun]   ./src/HelloWC_node
[rosrun]   ./devel/share/HelloWC_node
[rosrun]   ./devel/lib/HelloWC_node
[rosrun]   ./devel/lib/HelloWC_node/HelloWC_node
[rosrun]   ./build/HelloWC_node
[rosrun]   ./build/HelloWC_node/catkin_generated/stamps/HelloWC_node
robot@ASHROCK:~/Desktop/package_2$

Why is this going on? (i ran the source devel/setup.bash and it remains equal)

Thanks before hand!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-02-04 04:37:11 -0500

dornhege gravatar image

I believe your package is also named HelloWC_node, not just HelloWC.

edit flag offensive delete link more

Comments

Thanks, rosrun HelloWC_node HelloWC_node solved the Problem, what a confusion of names, i will more carefull with this!

pexison gravatar imagepexison ( 2015-02-04 05:25:38 -0500 )edit
1

answered 2015-02-04 02:23:51 -0500

Wolf gravatar image

Did you copy your workspace to a usb-stick with NTFS file system or zip file and back? The executable file flags get lost during this....

To solve this the easiest would probably be to rebuild your entire workspace. But delete the build and devel folders before because otherwise, if you did not make changes to the src files the build files will not be recreated.

i. e.

  • go to your workspace folder (the folder that contains src/ devel/ and build/ folders; where you called catkin_make)
  • run rm -r devel
  • run rm -r build
  • run catkin_make
  • run rosrun HelloWC HelloWC_node

and everthing should work again

edit flag offensive delete link more

Comments

Hi, no I just try to recompile yesterdays work, I already followed your instructions and the problem is half solved, now get this:

robot@ASHROCK:~/Desktop/package_2$ rosrun HelloWC HelloWC_node
[rospack] Error: stack/package HelloWC not found
pexison gravatar imagepexison ( 2015-02-04 02:56:46 -0500 )edit

Have you remembered to source devel/setup.bash after running catkin_make?

gvdhoorn gravatar imagegvdhoorn ( 2015-02-04 04:38:10 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-02-04 02:14:19 -0500

Seen: 57 times

Last updated: Feb 04 '15