Ask Your Question
0

Problems with using gmapping - cannot launch node.

asked 2015-01-09 06:55:09 -0500

sam3891 gravatar image

updated 2015-01-15 09:24:40 -0500

I request your help in getting started with gmapping on robotino. I have just checked out the robotino-ros-pkg using svn and run 'rosmake robotino' without any errors. Now when I want to launch gmapping using: roslaunch robotino_navigation gmapping.launch, I get the following error:

sam3891@sam3891-ThinkPad-SL400:~$ roslaunch robotino_navigation gmapping.launch
========

PARAMETERS
* /rosdistro: indigo
* /rosversion: 1.11.10
* /slam_gmapping/xmax: 20
* /slam_gmapping/xmin: -20
* /slam_gmapping/ymax: 20
* /slam_gmapping/ymin: -20

NODES
/
slam_gmapping (gmapping/slam_gmapping)
auto-starting new master
process[master]: started with pid [9008]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 3968f884-97fe-11e4-a8ea-0026186f16cc
process[rosout-1]: started with pid [9021]
started core service [/rosout]
ERROR: cannot launch node of type [gmapping/slam_gmapping]: gmapping
ROS path [0]=/opt/ros/indigo/share/ros
ROS path [1]=/usr/include/pcl-1.7/
ROS path [2]=/home/sam3891/robotino-ros-pkg
ROS path [3]=/opt/ros/indigo/share
ROS path [4]=/opt/ros/indigo/stacks

Is there any step that I am missing between download the robotino-ros-pkg and implementing gmapping? Do I need to download any extra packages? If so, how do I link it to ROS? Can someone help please?

Here is the gmapping.launch file:

<launch>
  <node name="slam_gmapping" pkg="gmapping" type="slam_gmapping">
    <param name="xmin" value="-20" />
    <param name="xmax" value="20" />
    <param name="ymin" value="-20" />
    <param name="ymax" value="20" />
  </node>
<!-- Run rviz -->
<include file="$(find robotino_navigation)/launch/rviz.launch" />
</launch>
edit retag flag offensive close merge delete

Comments

From the error it seems your ros package paths are not defined properly. Also share the contents of you launch file to know which nodes you are trying to run. Did you sourced your bashrc file with correct ros package path before launching the gmapping node?

AlexR gravatar image AlexR  ( 2015-01-10 06:16:27 -0500 )edit

Hi, the problem is I am not able to find the gmapping node. There are no source files in the 'robotino_navigation' folder. So my question is, do I need to download something else (some other package) to get Gmapping running?

sam3891 gravatar image sam3891  ( 2015-01-11 09:01:37 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-02-04 03:16:13 -0500

sam3891 gravatar image

I solved my problem by downloading the openslam_gmapping dependency ("http://wiki.ros.org/openslam_gmapping?distro=indigo") and then building it in the catkin workspace using "catkin_make". This generated an executable in the devel folder, which I copied and placed into the "bin" folder of "robotino_navigation".

edit flag offensive delete link more
1

answered 2015-01-15 09:41:02 -0500

cbandera gravatar image

I have not used the module yet, but I guess you have just downloaded the repo from here:? https://github.com/ros-perception/sla... If so, you have to put the folder into your workspace's src folder and compile it with catkin_make. Then you can source your workspaces devel/setup.bash.

Do the same with the robotino-pkg

edit flag offensive delete link more

Comments

Yes I tried it and got this error:

         Could not find a package configuration file provided by "openslam_gmapping"
           with any of the following names:

openslam_gmappingConfig.cmake
openslam_gmapping-config.cmake
sam3891 gravatar image sam3891  ( 2015-01-15 10:00:21 -0500 )edit

use the package here to solve the openslam problem: https://github.com/ros-perception/ope...

learner88 gravatar image learner88  ( 2016-01-14 21:09:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-01-09 06:55:09 -0500

Seen: 2,190 times

Last updated: Feb 04 '15