Ask Your Question
0

Node on RosAndroid is not receiving images from PC.

asked 2015-01-05 09:29:49 -0500

stark gravatar image

updated 2015-01-07 03:26:30 -0500

Hey guys, I have created a node on android to subscribe to a topic for images from PC. PC publishes images continuously & node on android phone subscribes for images. I have set the right IP to both ROS_MASTER_URI & ROS_IP as suggested here, http://answers.ros.org/question/72145... Still I am unable to achive it. So please let me know the solution, if anybody has here.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-01-07 01:53:42 -0500

gvdhoorn gravatar image

updated 2015-01-07 04:02:16 -0500

Somehow network setup with ROS Android seems to confuse many users.

We'll need some more information:

  1. Real Android device, or simulator
  2. Version of ROS, ROS Android & Android itself
  3. Network setup (LAN, WAN, etc)

Also, just to be clear: are you trying to subscribe on your Android device to topics published by your PC, or is the PC trying to subscribe to topics published by your Android device?


Edit: assumptions:

  1. you're using a physical Android device - not the simulator
  2. and both your ROS pc and the Android device are on the same network (a simple home LAN)
  3. you have checked that the Android device and the ROS pc have working IP connectivity
  4. you checked the Android application and that it is able to connect to ROS masters other than its own

Make sure your ROS pc has ROS_IP set to its own IP, and that ROS_MASTER_URI=http://$ROS_IP:11311/. In most cases, a home LAN doesn't have proper DNS for the pc and/or the Android device, resulting in strange behaviour. Setting ROS_IP should work around that.

On the Android device, make sure to use the ROS_MASTER_URI with the IP address of the master (pc), not its hostname.

Once the Android node should be connected, use roswtf, rosnode and rostopic to diagnose your graph.

edit flag offensive delete link more

Comments

I am trying to subscribe on android device. PC publishes images continuously..

stark gravatar imagestark ( 2015-01-07 02:37:51 -0500 )edit

Could you update your original question with the other information?

gvdhoorn gravatar imagegvdhoorn ( 2015-01-07 02:55:24 -0500 )edit

All your assumptions are correct.I am able to run android_pubsub tutorial successfully, but i am facing this problem with image_transport tutorial. I will now try to diagonise praph..

stark gravatar imagestark ( 2015-01-07 05:02:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-01-05 09:29:49 -0500

Seen: 695 times

Last updated: Jan 07 '15