Ask Your Question
0

Anyone use Zorin OS 9?

asked 2015-01-02 20:47:10 -0500

tman67 gravatar image

Just tried to install ROS on my computer. I am not totally new to Linux, but not a expert. I tried installing and it did not work.

Any step by step instructions would be appreciated.

Thanks...

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2015-01-03 08:27:13 -0500

gvdhoorn gravatar image

updated 2015-01-03 10:01:46 -0500

Caveat: I have no idea whether the following will work, but it is worth a shot.


According to distrowatch.com, Zorin OS 9 is based on Ubuntu. Ubuntu 14.04 (Trusty) to be precise, according to this post on their blog.

ROS Indigo can be installed on Ubuntu Trusty, but you'll have to help the ROS OS detector, since it doesn't know about Zorin OS. You could try to see whether setting ROS_OS_OVERRIDE is enough. Add the following to the end of your .bashrc file (which is in your home directory):

export ROS_OS_OVERRIDE=ubuntu:14.04

Then start a new terminal, and see if things start working.

PS: in the future, please add more information to your questions. We don't know which version of ROS you're trying to install, what kind of machine you have (32 or 64 bit), or even what "did not work". Simply stating that something didn't work is not sufficient. We don't have crystal balls ..

edit flag offensive delete link more
0

answered 2015-08-26 20:22:47 -0500

updated 2015-08-27 01:24:22 -0500

gvdhoorn gravatar image

I tried

export ROS_OS_OVERRIDE=ubuntu:14.04

to be able to perform rosdep update. It didn't work. Below is what happens when I try to run update. Is it possible to use ROS in Zorin OS or do I have to install an already supported distro?

root@Walkhard:~# sudo rosdep init
Wrote /etc/ros/rosdep/sources.list.d/20-default.list
Recommended: please run

    rosdep update

root@Walkhard:~# sudo rosdep update
reading in sources list data from /etc/ros/rosdep/sources.list.d
Warning: running 'rosdep update' as root is not recommended.
  You should run 'sudo rosdep fix-permissions' and invoke 'rosdep update' again without sudo.
Hit https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml
Hit https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml
Hit https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml
Hit https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml
Hit https://raw.githubusercontent.com/ros/rosdistro/master/releases/fuerte.yaml
Query rosdistro index https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml
Add distro "groovy"

ERROR: Rosdep experienced an error: Could not detect OS, tried ['windows', 'ubuntu', 'rhel', 'qnx', 'osx', 'opensuse', 'opensuse', 'mint', 'linaro', 'gentoo', 'freebsd', 'fedora', 'debian', 'cygwin', 'centos', 'arch']
Please go to the rosdep page [1] and file a bug report with the stack trace below.
[1] : http://www.ros.org/wiki/rosdep

rosdep version: 0.11.2

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/rosdep2/main.py", line 136, in rosdep_main
    exit_code = _rosdep_main(args)
  File "/usr/lib/python2.7/dist-packages/rosdep2/main.py", line 343, in _rosdep_main
    return _no_args_handler(command, parser, options, args)
  File "/usr/lib/python2.7/dist-packages/rosdep2/main.py", line 351, in _no_args_handler
    return command_handlers[command](options)
  File "/usr/lib/python2.7/dist-packages/rosdep2/main.py", line 533, in command_update
    error_handler=update_error_handler)
  File "/usr/lib/python2.7/dist-packages/rosdep2/sources_list.py", line 466, in update_sources_list
    rosdep_data = get_gbprepo_as_rosdep_data(dist_name)
  File "/usr/lib/python2.7/dist-packages/rosdep2/gbpdistro_support.py", line 147, in get_gbprepo_as_rosdep_data
    ctx = create_default_installer_context()
  File "/usr/lib/python2.7/dist-packages/rosdep2/__init__.py", line 85, in create_default_installer_context
    m.register_platforms(context)
  File "/usr/lib/python2.7/dist-packages/rosdep2/platforms/debian.py", line 50, in register_platforms
    register_linaro(context)
  File "/usr/lib/python2.7/dist-packages/rosdep2/platforms/debian.py", line 63, in register_linaro
    (os_name, os_version) = context.get_os_name_and_version()
  File "/usr/lib/python2.7/dist-packages/rosdep2/installers.py", line 112, in get_os_name_and_version
    os_name = self.os_detect.get_name()
  File "/usr/lib/python2.7/dist-packages/rospkg/os_detect.py", line 518, in get_name
    self.detect_os()
  File "/usr/lib/python2.7/dist-packages/rospkg/os_detect.py", line 488, in detect_os
    raise OsNotDetected("Could not detect OS, tried %s"%attempted)
OsNotDetected: Could not detect OS, tried ['windows', 'ubuntu', 'rhel', 'qnx', 'osx', 'opensuse', 'opensuse', 'mint', 'linaro', 'gentoo', 'freebsd', 'fedora', 'debian', 'cygwin', 'centos', 'arch']
edit flag offensive delete link more

Comments

First: do not run rosdep update with sudo (notice the warning in your console output). Second, try rosdep update --os="ubuntu:14.04" (could be that the quotes are unnecessary). rosdep sometimes needs a little more help. The rest of ROS should be fine with ROS_OS_OVERRIDE.

gvdhoorn gravatar imagegvdhoorn ( 2015-08-27 01:26:18 -0500 )edit

Also: sudo does not by default use the environment of the user that invoked it. So if you set ROS_OS_OVERRIDE in a shell run by your normal user, it will not be there in the shell that sudo uses. But you shouldn't use sudo for rosdep update anyway.

gvdhoorn gravatar imagegvdhoorn ( 2015-08-27 01:29:22 -0500 )edit
0

answered 2015-08-27 15:31:51 -0500

duck-development gravatar image

first befor you start delete the folder sudo -rf ~/./ros/

then you can rosdep update --os="ubuntu:14.04"

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-02 20:47:10 -0500

Seen: 393 times

Last updated: Aug 27 '15