Ask Your Question
1

ros indigo and opencv 3.0

asked 2014-12-07 04:30:43 -0500

meleagrosy gravatar image

Hi, I just wanted to ask how to use ros indigo with opencv 3.0.

I installed ros-indigo-opencv3 and compiled the latest opencv from source. When I create regular executables opencv 3.0 is used and it works fine, but when I use catkin_make, some packages use opencv 2.4.x and some 3.0 and then they do not work together. How do I hide opencv 2.4.x from being used?

Thanks

edit retag flag offensive close merge delete

Comments

CAn you help me with ros indigo and opencv 2.4.8 please? What did you put in Cmake list file and xml file

dmngu9 gravatar image dmngu9  ( 2015-05-08 23:53:03 -0500 )edit
lucasw gravatar image lucasw  ( 2015-11-30 16:32:18 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-12-07 23:39:07 -0500

meleagrosy gravatar image

nevermind. Some dependencies were using pre-built packages which used OpenCv 2.4.x. After recompiling these, everything worked fine.

edit flag offensive delete link more

Comments

Plz mark your own answer as accepted if issue is solved ;)

Wolf gravatar image Wolf  ( 2014-12-08 03:37:22 -0500 )edit

Could you clarify? Which dependencies in particular? Thanks.

jeremya gravatar image jeremya  ( 2015-09-28 21:46:38 -0500 )edit

I have the same problem. Could you explain me how to recompile to solve it? I am new here, thanks in advance

marilia15 gravatar image marilia15  ( 2015-10-06 15:27:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2014-12-07 04:30:43 -0500

Seen: 1,745 times

Last updated: Dec 07 '14