Ask Your Question
0

pocketsphinx indigo acoustic model missing parameter

asked 2014-12-04 17:54:49 -0600

csherstan gravatar image

I've tried this on 2 different computers now, both on Indigo, Linux Mint 17 (Ubuntu 14.04).

I simply do the install:

sudo apt-get install gstreamer0.10-pocketsphinx
sudo apt-get install ros-indigo-pocketsphinx
sudo apt-get install ros-indigo-audio-common

then run

roslaunch pocketsphinx robocup.launch

Which gives the error:

ERROR: "acmod.c", line 85: Acoustic model definition is not specified neither with -mdef option nor with -hmm
FATAL_ERROR: "fe_sigproc.c", line 405: Failed to create filterbank, frequency range does not match. Sample rate 8000.000000, FFT size 512, lowerf 5734.375000 < freq -15.625000 > upperf 5078.125000.

Anyone have any ideas? Sounds like there is a library mismatch to me. I've also tried this on hydro and had no problems.

Full console:

Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://bender:55109/

SUMMARY
========

PARAMETERS
 * /recognizer/dict: /opt/ros/indigo/s...
 * /recognizer/lm: /opt/ros/indigo/s...
 * /rosdistro: indigo
 * /rosversion: 1.11.9

NODES
  /
    recognizer (pocketsphinx/recognizer.py)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[recognizer-1]: started with pid [805]
[INFO] [WallTime: 1417734770.439411] Launch config: gconfaudiosrc
/opt/ros/indigo/lib/pocketsphinx/recognizer.py:68: SyntaxWarning: The publisher should be created with an explicit keyword argument 'queue_size'. Please see http://wiki.ros.org/rospy/Overview/Publishers%20and%20Subscribers for more information.
  self.pub = rospy.Publisher('~output', String)
[INFO] [WallTime: 1417734770.446870] Starting recognizer... 
INFO: cmd_ln.c(691): Parsing command line:
gst-pocketsphinx \
    -samprate 8000 \
    -cmn prior \
    -fwdflat no \
    -bestpath no \
    -maxhmmpf 2000 \
    -maxwpf 20 

Current configuration:
[NAME]      [DEFLT]     [VALUE]
-agc        none        none
-agcthresh  2.0     2.000000e+00
-alpha      0.97        9.700000e-01
-ascale     20.0        2.000000e+01
-aw     1       1
-backtrace  no      no
-beam       1e-48       1.000000e-48
-bestpath   yes     no
-bestpathlw 9.5     9.500000e+00
-bghist     no      no
-ceplen     13      13
-cmn        current     prior
-cmninit    8.0     8.0
-compallsen no      no
-debug              0
-dict               
-dictcase   no      no
-dither     no      no
-doublebw   no      no
-ds     1       1
-fdict              
-feat       1s_c_d_dd   1s_c_d_dd
-featparams         
-fillprob   1e-8        1.000000e-08
-frate      100     100
-fsg                
-fsgusealtpron  yes     yes
-fsgusefiller   yes     yes
-fwdflat    yes     no
-fwdflatbeam    1e-64       1.000000e-64
-fwdflatefwid   4       4
-fwdflatlw  8.5     8.500000e+00
-fwdflatsfwin   25      25
-fwdflatwbeam   7e-29       7.000000e-29
-fwdtree    yes     yes
-hmm                
-input_endian   little      little
-jsgf               
-kdmaxbbi   -1      -1
-kdmaxdepth 0       0
-kdtree             
-latsize    5000        5000
-lda                
-ldadim     0       0
-lextreedump    0       0
-lifter     0       0
-lm             
-lmctl              
-lmname     default     default
-logbase    1.0001      1.000100e+00
-logfn              
-logspec    no      no
-lowerf     133.33334   1.333333e+02
-lpbeam     1e-40       1.000000e-40
-lponlybeam 7e-29       7.000000e-29
-lw     6.5     6.500000e+00
-maxhmmpf   -1      2000
-maxnewoov  20      20
-maxwpf     -1      20
-mdef               
-mean               
-mfclogdir          
-min_endfr  0       0
-mixw               
-mixwfloor  0.0000001   1.000000e-07
-mllr               
-mmap       yes     yes
-ncep       13      13
-nfft       512     512
-nfilt      40      40
-nwpen      1.0     1.000000e+00
-pbeam      1e-48       1.000000e-48
-pip        1.0     1.000000e+00
-pl_beam    1e-10       1.000000e-10
-pl_pbeam   1e-5        1.000000e-05 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-02-26 04:01:55 -0600

you must specify : -lm -hmm -dict

otherwise it won't work

enjoy

edit flag offensive delete link more

Comments

Hello elpimous and csherstan

I have a related problem, but in my case, the -hmm parameter does not exist. I want to load the "pocketsphinx-0.4.0" spanish library but the node never ask me for a -hmm acustic language model. How I change that?

regards

hernan kirvit gravatar imagehernan kirvit ( 2015-09-04 14:34:38 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-12-04 17:54:49 -0600

Seen: 846 times

Last updated: Dec 04 '14