Ask Your Question
0

build hector_quadrotor in fedora 18

asked 2014-10-30 22:15:52 -0500

lordsairos gravatar image

updated 2014-10-30 22:21:34 -0500

ahendrix gravatar image

hello ROS es .. I want to build an run hector_quadrotor stack and its [slam indoor demo] ( http://wiki.ros.org/hector_quadrotor/... ) in Fedora .. I know that ros is more compatible with ubuntu .. I build ROS from source ..and now want to make hector as mentioned link , but i have problem .. when i run catkin_make I get som error :


CMake Error at /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:75 (find_package):
  Could not find a package configuration file provided by
  "hardware_interface" with any of the following names:

    hardware_interfaceConfig.cmake
    hardware_interface-config.cmake

  Add the installation prefix of "hardware_interface" to CMAKE_PREFIX_PATH or
  set "hardware_interface_DIR" to a directory containing one of the above
  files.  If "hardware_interface" provides a separate development package or
  SDK, be sure it has been installed.
Call Stack (most recent call first):
  hector_quadrotor/hector_quadrotor_controller/CMakeLists.txt:7 (find_package)

i know that i should resolve dependency and I run : rosdep install --from-paths src --ignore-src --rosdistro hydro -y but now i get these error :


hector_quadrotor_controller: No definition of [controller_interface] for OS version [spherical]
hector_quadrotor_teleop: No definition of [joy] for OS version [spherical]
hector_quadrotor_controller_gazebo: No definition of [gazebo_ros_control] for OS version [spherical]

i'm in Fedora 18 .. i'm sorry for that :! but i should use this distro .. please help me around these problem dears in ROS ...

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-10-30 22:31:20 -0500

ahendrix gravatar image

These messages indicate that you have missing dependencies.

Since you're on Fedora, you'll want to go to the wiki page (wiki.ros.org/package) for each ROS package that you need, and check out the hydro version of each package into your workspace.

If a particular package isn't a ROS package, you'll need to find the equivalent package in Fedora and install it through the package manager (yum, if I remember properly)

edit flag offensive delete link more

Comments

you are right dear Austin .. I should fetch dependency sources into src folder of my catkin work space, and rosdep update and install them using catkin_make . i think ROS has not a handy and standard route for building packages .. the user but not developers may get confused .. i'm trying.

lordsairos gravatar image lordsairos  ( 2014-10-31 10:16:18 -0500 )edit

I haven't used it much, but I think the rosinstall_generator can help download the proper dependencies automatically.

ahendrix gravatar image ahendrix  ( 2014-10-31 11:28:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-30 22:15:52 -0500

Seen: 255 times

Last updated: Oct 30 '14