Ask Your Question
2

rosrun warning error

asked 2014-10-30 01:51:05 -0500

ASHISH CHHONKAR gravatar image

i created a simple package for listner.cpp and talker.cpp. i already build my package. when i run "rosrun firstpack talker", it run successfully and print "hello world". when i open new tab and run my listener node it give me error .

chhonkar@chhonkar-pc:~/Desktop/catkin$ rosrun firs[rospack] Warning: error while crawling /home/chhonkar: boost::filesystem::status: Permission denied: "/home/chhonkar/.gvfs" tpack listner [rosrun] Couldn't find executable named listner below /home/chhonkar/Desktop/catkin/src/firstpack

Both node run successfully when i run it alone. but when i run another node, it return error. my questions are Q1- " what is this error?" Q2 - "why my node run alone but when i execute one after another, it fails and return above error"?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-10-30 02:11:03 -0500

ahendrix gravatar image

I see two separate issues here:

  1. You have a permissions problem with your ~/.gvfs directory. I suspect you see this warning when you try to tab-complete your package name. I haven't seen this before; you'll probably want to search the Ubuntu forums or just try rebooting.
  2. Your environment isn't set up properly in your new terminal. Are you sure you're sourcing the setup.bash for your workspace properly? (Note that with catkin, setting the ROS_PACKAGE_PATH manually is no longer sufficient to tell ROS where your workspace is).
edit flag offensive delete link more
6

answered 2014-10-30 09:41:19 -0500

ROSCMBOT gravatar image

According to this, running these two commands

#umount /home/useraccount/.gvfs
#rm -rf .gvfs/

will fix the first issue.

edit flag offensive delete link more

Comments

Problem goes different. this time, nodes are not running. I rebuild the package. and when i use the command "rosrun firstpack talker", it return chhonkar@chhonkar-pc:~/Desktop/catkin$ rosrun firstpack talker [rosrun] Couldn't find executable named talker below /home/chhonkar/Desktop/catkin/src/first

ASHISH CHHONKAR gravatar image ASHISH CHHONKAR  ( 2014-10-30 10:52:07 -0500 )edit

In the new tab, did you run 'source devel/setup.bash' in your workspace?

ROSCMBOT gravatar image ROSCMBOT  ( 2014-10-30 19:41:50 -0500 )edit

i got the solution. what i did, first run roscore, open new tab and execute export path and source path command and run the rosrun firstpack talker. open new tab, and AGAIN execute export and source command and then run rosrun firstpack listener. ........ it works fine.

ASHISH CHHONKAR gravatar image ASHISH CHHONKAR  ( 2014-10-31 01:46:40 -0500 )edit

Is there any way to fixed or save ROS_PACKAGE_PATH and SOurce command , so that i did not required to define ROS_PACKAGE_PATH AND SOURCE again and again.???

ASHISH CHHONKAR gravatar image ASHISH CHHONKAR  ( 2014-10-31 01:48:09 -0500 )edit

You can add them in your ~/.bashrc file

ROSCMBOT gravatar image ROSCMBOT  ( 2014-10-31 02:16:59 -0500 )edit

i am just new to ubuntu, can you tell me where i can find it.... and how i can??

ASHISH CHHONKAR gravatar image ASHISH CHHONKAR  ( 2014-10-31 03:27:30 -0500 )edit

run sudo gedit ~/.bashrc

ROSCMBOT gravatar image ROSCMBOT  ( 2014-10-31 03:45:51 -0500 )edit

@ROSCMBOT how can i add the path to this file. when i run this command. a horrible file open which is difficult to understand. Please help me.

ASHISH CHHONKAR gravatar image ASHISH CHHONKAR  ( 2014-11-04 06:09:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-30 01:51:05 -0500

Seen: 4,106 times

Last updated: Oct 30 '14