Ask Your Question
1

rviz black background in menu

asked 2014-10-06 14:28:15 -0500

goupil35000 gravatar image

updated 2014-10-07 08:21:18 -0500

Hello,

I want to use rviz with a webcam. I'm not able to launch rviz if LIBGL_ALWAYS_SOFTWARE is not defined. I need to do "export LIBGL_ALWAYS_SOFTWARE=0". If I go out of rviz and I want to use it again it will not work. Sometimes it will work again but I need to modify LIBGL_ALWAYS_SOFTWARE (sometimes 0 and sometimes work only with 1 ?).

But at this time, the biggest problem is that all menu have black background. The center part and the bottom are grey, so no problem to read text on it. But the left part, the right part and the upper part have black background. I can see there are some menus, but impossible to read. In the upper part, I have just icons which I can see.

So I change theme, I tested with Ubuntu Interface, Cinnamon Interface, I used with 1 external monitor so I disconnected it but ... it's always the same.

So my question is simple: how can I change the background of these black parts before launching rviz ? Or may be there is another problem ?

Thanks for reply.

Goupil

Configuration: Zenbook UX32VD (only graphics from Intel I7) / Ubuntu 14.04 / ROS Indigo / OpenGl 4.4 /rviz 1.11.3

Edit: Tested after switching to Nvidia 620m card. It's the same, black background for menus. I remove ~/.rviz, same problem. To launch rviz it seems that it works sometimes (1 times / 3 tries) with intel graphics but it launches more often with Nvidia. It's independant of the value of LIBGL_ALWAYS_SOFTWARE (but it seems slower when this variable is on 1).

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2014-10-13 06:03:34 -0500

Andromeda gravatar image

I can strongly suggest you to remove the nouveau driver coming as default with ubuntu and install the closed sources driver from Nvindia. Here an awesome tutorial. I solved problem like that removing the nouveau and installing the Nvidia propretary drivers.

Regards

edit flag offensive delete link more
2

answered 2015-01-21 13:02:54 -0500

rand gravatar image

I had the same problem running Cinnamon on Ubuntu 14.04 with my GeForce GT 650M (Mac Edition). I fixed it by running:

  gtk-theme-config

and then turning "Custom Panel Colors" to on.

Theme Configuration Panel

edit flag offensive delete link more

Comments

That's great. Thank you very much!

spurs9528 gravatar image spurs9528  ( 2017-03-21 07:46:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-06 14:28:15 -0500

Seen: 1,662 times

Last updated: Oct 13 '14