ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

XV_laser_drive/Tutorial

asked 2014-09-01 12:06:50 -0500

Morpheus gravatar image

I did a upgrade to Indigo so I could get Rviz working properly. I am trying to install the xv_laser_driver. I get an error with catkin_make. This is what I get:

Base path: /home/brent/catkin_ws Source space: /home/brent/catkin_ws/src Build space: /home/brent/catkin_ws/build Devel space: /home/brent/catkin_ws/devel Install space: /home/brent/catkin_ws/install ####

Running command: "make cmake_check_build_system" in "/home/brent/catkin_ws/build"

#### ####

Running command: "make -j2 -l2" in "/home/brent/catkin_ws/build"

#### [ 0%] Built target _beginner_tutorials_generate_messages_check_deps_AddTwoInts [ 0%] Built target _beginner_tutorials_generate_messages_check_deps_Num [ 0%] Built target std_msgs_generate_messages_lisp [ 0%] Built target std_msgs_generate_messages_cpp [ 0%] Built target std_msgs_generate_messages_py [ 16%] [ 25%] Built target rbx1_nav_gencfg Building CXX object xv_11_laser_driver/CMakeFiles/neato_laser_publisher.dir/src/neato_laser_publisher.cpp.o [ 41%] Built target beginner_tutorials_generate_messages_lisp [ 58%] Built target beginner_tutorials_generate_messages_cpp [ 91%] Built target beginner_tutorials_generate_messages_py [ 91%] Built target beginner_tutorials_generate_messages [100%] Building CXX object xv_11_laser_driver/CMakeFiles/neato_laser_publisher.dir/src/xv11_laser.cpp.o /home/brent/catkin_ws/src/xv_11_laser_driver/src/xv11_laser.cpp: In member function ‘void xv_11_laser_driver::XV11Laser::poll(sensor_msgs::LaserScan_<std::allocator<void> >::Ptr)’: /home/brent/catkin_ws/src/xv_11_laser_driver/src/xv11_laser.cpp:109:7: error: ‘rpms’ was not declared in this scope rpms=0; ^ make[2]: * [xv_11_laser_driver/CMakeFiles/neato_laser_publisher.dir/src/xv11_laser.cpp.o] Error 1 make[2]: Waiting for unfinished jobs.... /home/brent/catkin_ws/src/xv_11_laser_driver/src/neato_laser_publisher.cpp: In function ‘int main(int, char)’: /home/brent/catkin_ws/src/xv_11_laser_driver/src/neato_laser_publisher.cpp:71:23: error: ‘class xv_11_laser_driver::XV11Laser’ has no member named ‘rpms’ rpms.data=laser.rpms; ^ make[2]: * [xv_11_laser_driver/CMakeFiles/neato_laser_publisher.dir/src/neato_laser_publisher.cpp.o] Error 1 make[1]: [xv_11_laser_driver/CMakeFiles/neato_laser_publisher.dir/all] Error 2 make: * [all] Error 2 Invoking "make" failed

I know you guys are probably tired from my on going problem with this tutorial, but I do appreciate your help.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2014-09-08 05:58:26 -0500

pikey gravatar image

No need to comment anything, just declare rpms in xv11_laser.h

gedit ~/catkin_ws/src/xv_11_laser_driver/include/xv_11_laser_driver/xv11_laser.h

Add the following to line 43 after public: then save the file

uint16_t rpms;

Run catkin_make in your catkin workspace, and you should be all good now :)

cd ~/catkin_ws/
catkin_make
source devel/setup.bash

Tested with a Jeston TK1 running Ubutnu 14.04 & Indigo

edit flag offensive delete link more

Comments

Worked perfect.
Thank you!

Morpheus gravatar image Morpheus  ( 2014-09-15 06:00:20 -0500 )edit
0

answered 2014-09-07 13:46:14 -0500

Hi , I just had the same error also with indigo, I fixed it by adding a "uint16_t rpms; " definition to the vx11_laser.cpp file and then it gave an error in the publisher file which i got around by commenting out the line " // rpms.data=laser.rpms; " after that the catkin_make worked ok. then had to run sudo su to let rosrun to be found and allow the ttyUSB0 port to be opened. Laser scan now displaying in rviz ! Im not a SW eng and its a bit of a hack, the rpm data is most likley not critical anyway , hope it works for you.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-09-01 12:06:50 -0500

Seen: 324 times

Last updated: Sep 08 '14