Ask Your Question
0

problem with rosmsg - tutorial

asked 2014-08-07 10:52:08 -0500

ilymperopo gravatar image

Greetings,

I am using the Indigo installation, with Ubuntu 14.04 in VirtualBox.

I am following the ROS tutorials and I am currently having problems with ros messages

I follow everything as described

  1. Create a new message called Num.msg, under folder beginner_tutorials/msg.
  2. Modify the CMakeLists.txt file as described.
  3. Run catkin_make

Everything compiles beautifully. I then try to run

rosmsg show beginner_tutorials/Num

and I get a huge list of locations where ros was searching (unsuccesfully to locate the msg).

Then I run

rosmsg list

and I don't see my beginner_tutorials/Num in the list.

Am I missing something? How do I add my newly defined msg in the ros list of messages?

Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2014-08-07 11:26:59 -0500

Chrissi gravatar image

Did you source your workspace?

In your workspace there should be a devel directory containing a setup.bash try source setup.bash and then run your commands again.

Actually this setup.bash file tells ros where to look for messages, nodes, service, etc. and if you do not source it, it will not look in your workspace.

edit flag offensive delete link more

Comments

thanks source devel/setup.bash solved my problem

ilymperopo gravatar image ilymperopo  ( 2014-08-07 11:43:28 -0500 )edit
1

add that to your .bashrc file in your home folder so it will source everytime you open up a new terminal

l0g1x gravatar image l0g1x  ( 2014-08-07 12:18:28 -0500 )edit

that's a great idea

ilymperopo gravatar image ilymperopo  ( 2014-08-07 12:35:31 -0500 )edit

That is why it is stated in the tutorials :)

l0g1x gravatar image l0g1x  ( 2014-08-07 12:41:45 -0500 )edit
1

Indeed, even though the confusion comes from the fact that sourcing is not repeated in the rosmsg beginners tutorial. But, maybe this serves a purpose, now I know!

ilymperopo gravatar image ilymperopo  ( 2014-08-07 15:40:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-07 10:52:08 -0500

Seen: 236 times

Last updated: Aug 07 '14