interactive markers not working after changing from KDL to IKFast

asked 2014-08-04 07:32:58 -0500

Frantisek.Durovsky gravatar image

I ve been working on 6DOF SEF-Roboter model for couple weeks now. I have successfully generated URDF from solidoworks model, created moveit package where using KDL plugin interactive markers as well as move_group interface were working without any problem.

Last week I tried to switch from KDL plugin to IKFast. Finnaly I manage to generate ikfast.cpp library as well as moveit plugin following moveit IKFast tutorial. When launching demo.launch with IKFast everythinhg looks ok in RViz except interactive markers functionality. As shown in video I am able to change goal and start state using random values and trajectory planning works well, the problem I have is that I m not able to drag the manipulator using interactive markers, start and goal state almost to not react to any movement

Very rarely I m able to change robot goal or state position changing orientation of the marker. Another problem, when trying to access planning interface from code via move_group functions, I get errors : manipulator[LBKPIECEkConfigDefault]: Unable to sample any valid states for goal tree Using the same node with KDL plugin works fine

I have also generated two versions of IKFast using rounded and unrounded dae. file, but with no success

Any ideas ?

Using ROS Hydro on Ubuntu 12.04

edit retag flag offensive close merge delete


Do you get any output on the console when dragging the interactive marker? Depending on how you generated the IKFast plugin, the starting pose of your manipulator may simply be unsolvable for your plugin. The console typically gets spammed with error messages in that case though.

gvdhoorn gravatar image gvdhoorn  ( 2014-08-04 07:53:12 -0500 )edit

No different output on the console when moving IM at all, just standard info e.g: [ INFO] [1407158949.470709471]: Loading robot model 'sef_roboter'... [ INFO] [1407158950.253163679]: Starting scene monitor [ INFO] [1407158950.254830810]: Listening to '/move_group/monitored_planning_scene' [ WARN] [1407158950.949564544]: The root link base_link has an inertia specified in the URDF, but KDL does not support a root link with an inertia. As a workaround, you can add an extra dummy link to your URDF. [ INFO] [1407158951.022810887]: Constructing new MoveGroup connection for group 'manipulator' [ INFO] [1407158951.913712401]: Ready to take MoveGroup commands for group manipulator. [ INFO] [1407158951.913823998]: Looking around: no [ INFO] [1407158951.914008551]: Replanning: no

Frantisek.Durovsky gravatar image Frantisek.Durovsky  ( 2014-08-04 08:45:06 -0500 )edit

Hi! I have the same problem, have you solved the problem?

Huitan gravatar image Huitan  ( 2015-04-11 09:48:48 -0500 )edit

Hi! I'm also having the same problem. Have you found the solution?

Jangwon gravatar image Jangwon  ( 2016-05-29 18:34:18 -0500 )edit

IKFast algorithm was just not able to compute solutions for most of the poses. I rather returned back to KDL which seems to be more stable to me. But there is also a new solver that might be worth trying:

Frantisek.Durovsky gravatar image Frantisek.Durovsky  ( 2016-05-30 03:34:37 -0500 )edit

@Frantisek.Durovsky - Thanks for letting me know. The new solver sounds interesting, but I want to use IK with Moveit! framework, so I have no idea that new solver can be used with Moveit!. Anyway, Thanks!

Jangwon gravatar image Jangwon  ( 2016-05-31 12:25:06 -0500 )edit

Yes, it can be used with MoveIt.

gvdhoorn gravatar image gvdhoorn  ( 2016-05-31 12:48:11 -0500 )edit

Yes, I just realized it the package provides Moveit! plugin. Thanks!

Jangwon gravatar image Jangwon  ( 2016-05-31 13:06:43 -0500 )edit