Ask Your Question
0

libuvc_camera: Library not loaded with indigo on osx

asked 2014-07-14 05:47:24 -0600

J.M.T. gravatar image

Hello,

when it try to run my webcam with libuvc_camera:

sudo -E rosrun libuvc_camera camera_node vendor:=0x046d
dyld: Library not loaded: librospack.dylib
  Referenced from: /opt/ros/indigo/bin/rospack
  Reason: image not found

But librospack.dylib is compiled fresh and sitting in /opt/ros/indigo/lib/librospack.dylib. Why is it not being found? Is there something wrong with my paths?

edit retag flag offensive close merge delete

Comments

I guess with your answer to your other question you don't need to resolve this any more?

demmeln gravatar imagedemmeln ( 2014-07-14 19:37:00 -0600 )edit

No, unfortunately this still needs to be resolved. I gave up the isight but really need a camera. Thus I've settled for a fairly standard Logitech c270...

J.M.T. gravatar imageJ.M.T. ( 2014-07-15 01:07:52 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-07-15 05:51:18 -0600

demmeln gravatar image

I would start by not using sudo, which is not well supported by rosrun. Does the error persist?

If you don't have permission to access the device, change them temporarily using chmod, or permanently with udev.

edit flag offensive delete link more

Comments

You are right, i only tried sudo -E because it was recommended in the wiki. Of course I tried without sudo before but had a different error:

J.M.T. gravatar imageJ.M.T. ( 2014-07-15 06:39:56 -0600 )edit

ros::InvalidNameException: Character [0] is not valid as the first character in Graph Resource Name [0x046d]. Turned out the leading 0 in 0x046d was the real problem.

J.M.T. gravatar imageJ.M.T. ( 2014-07-15 06:41:01 -0600 )edit

For the record, could you state the command line invocation that worked for you (dealing with the leading 0)?

demmeln gravatar imagedemmeln ( 2014-07-15 06:56:59 -0600 )edit

Sure, rosrun libuvc_camera camera_node vendor:=x046d

J.M.T. gravatar imageJ.M.T. ( 2014-07-15 06:58:24 -0600 )edit

Ah ok, thanks!

demmeln gravatar imagedemmeln ( 2014-07-15 06:59:15 -0600 )edit

Thanks! It works for me!

zipper1956 gravatar imagezipper1956 ( 2014-08-10 09:24:48 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-14 05:47:24 -0600

Seen: 502 times

Last updated: Jul 15 '14