Ask Your Question
0

pocketsphinx excessively verbose

asked 2014-07-08 09:18:42 -0500

Alex Brown gravatar image

Now that I have pocketsphinx running well, I am launching it with a number of other nodes. The basic pocketsphinx program prints many "INFO:" statements as it processes the voice input. This makes any messages printed by my other nodes unusable since they scroll off the screen rapidly.

Not using "output="screen" when recognizer.py is launched only stops the messages from recognizer.py, not from pocketsphinx.

Can anyone tell me how to stop these messages?

Thanks, Alex

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-02-15 12:02:25 -0500

Kristof gravatar image

Try playing with the logfn parameter:

E.g. from http://stackoverflow.com/questions/17... :

pocketsphinx_continuous -logfn /dev/null

Or write to file:

pocketsphinx_continuous -logfn [file]

In python (what ros pocketsphinx is using), from https://mattze96.safe-ws.de/blog/?p=640 :

self.asr.set_property('logfn', '/dev/null')
edit flag offensive delete link more

Comments

This worked.. For windows Users, use pocketsphinx_continuous -logfn NUL

vikz91 gravatar image vikz91  ( 2016-01-06 00:15:50 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-08 09:18:42 -0500

Seen: 804 times

Last updated: Feb 15 '15