Ask Your Question
0

Cannot install rosserial in ros indigo

asked 2014-06-18 22:23:03 -0500

robospace gravatar image

When tried to install rosserial using sudo apt-get install ros-indigo-rosserial it returns an error E: Unable to locate package ros-indigo-rosserial

I am using ros indigo on ubuntu 14.04

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-06-19 01:46:11 -0500

gvdhoorn gravatar image

updated 2014-06-19 01:46:56 -0500

While rosserial has been released into Indigo (see debbuild/indigo.html?q=serial for instance), it appears it hasn't yet been synced with the main repositories, which could be why apt-get cannot find it.

It is currently available from the ros-shadow-fixed repository, see ros-shadow-fixed/pool/ros-indigo-rosserial.

So it appears we'll have to wait for the next 'sync', which will be announced on the mailing lists.

edit flag offensive delete link more

Comments

Can we use any methods other than apt-get to install rosserial in indigo?

robospace gravatar image robospace  ( 2014-06-19 05:08:49 -0500 )edit

Sure. If you already have a catkin workspace (for your own pkgs fi), just checkout rosserial into it (look on the wiki for the github url), then build it like any other catkin package. Alternatively (but not really recommended), you could try to download the *.debs and install those using dpkg.

gvdhoorn gravatar image gvdhoorn  ( 2014-06-19 05:30:58 -0500 )edit

Please share the links from which we can get the *,debs, if you know. Thanks for the help.

robospace gravatar image robospace  ( 2014-06-19 08:02:12 -0500 )edit

I would build from source, but I already gave the link: go to the ros-shadow-fixed/pool/ros-indigo-rosserial link I posted, go up one level, then down to ros-indigo-rosserial-{client,server,..} you'll find the debs for each supported architecture. Dependency resolution might still fail though.

gvdhoorn gravatar image gvdhoorn  ( 2014-06-19 08:28:12 -0500 )edit

If you are using indigo right now, it's still in beta and so you might as well be using ros-shadow-fixed. Update your /etc/apt/sources files to point at ros-shadow-fixed and you should have rosserial.

fergs gravatar image fergs  ( 2014-06-19 22:47:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-06-18 22:23:03 -0500

Seen: 1,496 times

Last updated: Jun 19 '14