can't build pr2_object_manipulation: no common_msgs??

asked 2014-04-30 15:18:19 -0600

mbforbes gravatar image

updated 2014-04-30 15:19:18 -0600

I'm hoping to catkin-ize and then hydro-ize pr2_object_manipulation. However, first I want to get the code to build in the last supported state (rosbuild, groovy).

When building, I get Built 260 packages with 1 failures. and the failure is that it can't find common_msgs. Indeed, running rosdep check pr2_object_manipulation gives:

All system dependencies have been satisified
ERROR[pr2_interactive_manipulation]: resource not found [common_msgs]

However, sudo apt-get install ros-groovy-common-msgs says they're installed. Running roscd common_msgs take me to /opt/ros/groovy/share/common_msgs, though it just has a package.xml file in it.

I would just check out and build common_msgs itself, but it's in catkin since groovy. Any help would be greatly appreciated!

On Ubuntu 12.04.

edit retag flag offensive close merge delete

Comments

Has this been solved? I know there has been a lot of development by you on the PR2 repo, so just curious if this is still an open issue?

DevonW gravatar imageDevonW ( 2014-07-13 04:39:26 -0600 )edit

Thanks for your interest @DevonW! Regrettably it seems no one can build it; check out this thread on its github repository: https://github.com/ros-interactive-ma... . It seems like switching to MoveIt! is probably the best course of action at this point.

mbforbes gravatar imagembforbes ( 2014-08-10 18:42:00 -0600 )edit