rosws init ~/rosbuild_ws ~/catkin_ws/devel not working?

asked 2014-04-23 13:24:50 -0600

Pi Robot gravatar image

Hello, I recently followed the instructions given here so that I could run both rosbuild and catkin workspaces together. However, even after adding the line:

source ~/rosbuild_ws/setup.bash

to the end of my .bashrc file and bringing up a new terminal, my ~/rosbuild_ws directory is not in my ROS_PACKAGE_PATH. This means (among other things) that I can't run rosmake on a package located under ~/rosbuild_ws. Or, if I already have a package under ~/rosbuild_ws like ~/rosbuild_ws/my_package, I cannot use 'roscd' to move into it:

$ roscd my_package
roscd: No such package/stack 'my_package'

I can work around the problem by manually adding ~/rosbuild_ws to my ROS_PACKAGE_PATH, but shouldn't using 'rosws init ~/rosbuild_ws ~/catkin_ws/devel' make this unnecessary?


edit retag flag offensive close merge delete