Ask Your Question
0

segmentation fault at rosrun rviz rviz

asked 2014-04-08 19:52:54 -0500

Ken_in_JAPAN gravatar image

updated 2014-04-09 07:07:29 -0500

I came across a segmentation fault while trying rosrun rviz rviz. This issue has been discussed on this web( http://answers.ros.org/question/11376... ), but I think that essential issue has been not solved. The solution in the comment and the answer was to delete all of file in ~/.rviz. I also deleted all of files as I follow the instruction. But, the error doesn't go out.

[ INFO]rviz version 1.10.14
[ INFO]compiled against OGRE version 1.7.4 (Cthugha)
[ INFO]Stereo is NOT SUPPORTED
[ INFO]OpenGl version: 2.1 (GLSL 1.2)
Segmentation fault

I have checked the article ( http://wiki.ros.org/rviz/Troubleshooting ). I can't find the way to solve the issue on the article. Could anyone give me clues? Thank you in advance!

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2014-04-08 20:22:05 -0500

The type of graphics card you use always is crucial when looking at rviz crashes (you can edit your answer to add that information). The rule of thumb is: "Nvdidia GPUs with propietary drivers generally work well, others might crash occasionally (or always in a absolute worst case)". With your GPU and driver known, I´d recommend googling something like "rviz crashes ros answers [your graphics card type]". There are tons of posts on rviz crashes on ROS Answers and it´s likely that there will be useful information in some of them.

edit flag offensive delete link more

Comments

@Stefan Kohlbrecher: Thank you for your advice! I will check it out tomorrow. Sorry, here is at midnight.

Ken_in_JAPAN gravatar image Ken_in_JAPAN  ( 2014-04-08 21:05:20 -0500 )edit

@Stefan Kohlbrecher: I was looking over the article on the web(http://wiki.ros.org/rviz/Tutorials/Rviz%20in%20Stereo). Do you think that this contents connects with my issues?

Ken_in_JAPAN gravatar image Ken_in_JAPAN  ( 2014-04-08 21:10:50 -0500 )edit

Unless you try something with stereo mode, no. I assume you installed from .deb packages?

Stefan Kohlbrecher gravatar image Stefan Kohlbrecher  ( 2014-04-08 22:23:24 -0500 )edit

I don't make sense, I was googling to search for the cause and how to fix it. I also tried the method on the web (https://github.com/ros-visualization/rviz/issues/713), but segmentation fault didn't go out. I will reinstall.

Ken_in_JAPAN gravatar image Ken_in_JAPAN  ( 2014-04-09 15:48:52 -0500 )edit
2

answered 2017-04-16 18:42:41 -0500

sachitv gravatar image

Hi all,

I spent a load of time fixing these issues. What I realised is that Virtualbox is being a nasty little rascal with it's 3d Acceleration.

Switching if off fixed these issues for me.

Switch off your VM Just go to the VM Settings -> Display -> Uncheck Enable 3D Acceleration. Start your VM again. Rejoice!

edit flag offensive delete link more

Comments

Thank you! This worked for me.

iguanaistic gravatar image iguanaistic  ( 2017-04-21 23:08:15 -0500 )edit
0

answered 2014-09-22 20:21:05 -0500

130s gravatar image

I've been bugged by the error with the same message, which recently I've solved in this thread. HTH.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-08 19:52:54 -0500

Seen: 6,477 times

Last updated: Sep 22 '14