Ask Your Question
3

nodelets running with remote roscore are dying (bond broken)

asked 2014-04-03 04:44:59 -0600

madmage gravatar image

Hi all (or, at least, the usual one who answers to my questions ;-)), I have the following situation:

  • LAPTOP1: roscore, roslaunch with openni_node and some tf
  • LAPTOP2: roslaunch with some depth_image_proc nodelets, connected via ROS_MASTER_URI=http://LAPTOP1

the problem is that the nodelets on LAPTOP2 are alive only for a short while (some seconds), then, they start to die, one after the other:

[ INFO] [1396535717.713638183]: Bond broken, exiting
[camera/register_depth_rgb-3] process has finished cleanly

What's going on? How can I run this configuration properly? Thanks

edit retag flag offensive close merge delete

Comments

I tested also what happens without the **openni_node** on LAPTOP1 (i.e., there is no input for the nodelets on LAPTOP2, so they should not run, since their subscribed topics are not published): same behavior

madmage gravatar imagemadmage ( 2014-04-03 04:48:10 -0600 )edit

What happens when you start the roscore on laptop2 instead?

demmeln gravatar imagedemmeln ( 2014-04-03 05:27:09 -0600 )edit

Moreover, do other nodes / nodelets have the same problems on laptop2, or is it just the image_proc nodelets?

demmeln gravatar imagedemmeln ( 2014-04-03 05:27:49 -0600 )edit

I can run the nodelets on laptop2 with a roscore on laptop2, everything works (this is actually how everything has begun). Can you tell me a simple nodelet I can test (to see if it's a depth_image_proc problem or nodelet problem)?

madmage gravatar imagemadmage ( 2014-04-03 06:30:57 -0600 )edit

Have you tried simple nodes on laptop2 with core on laptop1? Something like `rostopic pub` or `rostopic sub`?

demmeln gravatar imagedemmeln ( 2014-04-03 06:55:00 -0600 )edit

The openni_node running on laptop1 publishes /camera/rgb/image_raw and /camera/depth/image_raw (roscore is on laptop1), I can see that image by subscribing it from laptop2 with rqt_image_view.

madmage gravatar imagemadmage ( 2014-04-03 07:14:59 -0600 )edit

Ok. I don't know what could be the problem, sorry. @esteve, @tfoote, any idea how to investigate this best?

demmeln gravatar imagedemmeln ( 2014-04-04 01:12:18 -0600 )edit

I rewrote launch files, rebooted laptops, upgraded packages... now it works (more or less)... could it be that was because I had image_transport package installed on one laptop (LAPTOP1) and not the other?

madmage gravatar imagemadmage ( 2014-04-04 01:42:06 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
4

answered 2014-04-04 05:25:05 -0600

madmage gravatar image

So, summarizing, I just resolved by rebooting both machines, rewriting both launch files, installing missing image_transport plugins on LAPTOP2.

edit flag offensive delete link more
0

answered 2017-09-08 12:11:06 -0600

delekx gravatar image

For me a simple reboot to both machines did the trick.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-03 04:44:59 -0600

Seen: 2,137 times

Last updated: Apr 04 '14