ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

rviz does not run on virtual machine - Illegal instruction (core dumped)

asked 2014-03-25 17:57:26 -0600

Warrior gravatar image

updated 2014-03-26 03:46:01 -0600

Hi everyone,

I am using Ubuntu 12.04 32-bit on VirtualBox. I just installed the rviz and tried to run it using "rosrun rviz rviz" command. But the followings will be shown and it doesn't start. How can I fix the issue?

[ INFO] [1395806079.738572838]: rviz version 1.10.11
[ INFO] [1395806079.739463083]: compiled against OGRE version 1.7.4 (Cthugha)
[ INFO] [1395806080.677327493]: OpenGl version: 2.1 (GLSL 1.2).
Illegal instruction (core dumped)

I may note that I enabled 3D acceleration before turning on the virtual machine, but the system details there is no sign of having a 128 MB graphics card. Also, I executed the following code, but rviz does not run yet:


Thank you

edit retag flag offensive close merge delete


Do other opengl applications work? Try apt-getting mesa-utils and running glxgears to make sure that a simple opengl application works.

jbinney gravatar image jbinney  ( 2014-03-25 20:47:01 -0600 )edit

No it doesn't run ... Illegal instruction (core dumped) What should I do? :(

Warrior gravatar image Warrior  ( 2014-03-26 03:55:07 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2014-03-26 06:57:30 -0600

Warrior gravatar image

Guys, I solved the issue partially.

The problem was stemming from lack of 3D support in the Ubuntu installed as virtual machine.

Now, when I execute the command "glxgears" it runs having no problem. But when I execute the command

rosrun rviz rviz

it shows a segmentation fault. How should I resolve this issue?

edit flag offensive delete link more



Do you have anything odd in your rviz config file? If not, you may have to resort to running rviz in gdb, getting a backtrace, and filing a bug here:

jbinney gravatar image jbinney  ( 2014-03-26 23:30:39 -0600 )edit

No, I haven't touched the rviz config file. I actually don't know where it is. I'm confused now. I need to work with rviz but I don't know how to ... . The link you provided doesn't work.

Warrior gravatar image Warrior  ( 2014-03-27 14:53:48 -0600 )edit
<p> seems to append characters to the link :-( Copy/paste it manually: ""

jbinney gravatar image jbinney  ( 2014-03-27 15:13:30 -0600 )edit

answered 2014-03-26 00:15:55 -0600

gvdhoorn gravatar image

Illegal instruction errors pop up when you try to run a binary compiled to use instructions that your CPU does not have (ie: trying to use SSE4 when you only have SSE3). I've never seen using a VM cause those kind of errors.

edit flag offensive delete link more


How can I use SSE4 instead of SSE3? I may note that when I execute the rosrun rviz rviz command, rviz window opens up partially, but it doesn't show anything and closes suddenly.

Warrior gravatar image Warrior  ( 2014-03-26 03:44:58 -0600 )edit

Also, when I execute the command glxgears it shows me the same error message "Illegal instruction (core dumped)"

Warrior gravatar image Warrior  ( 2014-03-26 03:55:55 -0600 )edit

Question Tools

1 follower


Asked: 2014-03-25 17:57:26 -0600

Seen: 1,528 times

Last updated: Mar 26 '14