ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

packages url Ubuntu12.04 armhf

asked 2014-03-20 08:39:11 -0500

hvn gravatar image

updated 2014-03-20 11:16:15 -0500

ahendrix gravatar image

Hi,

While running apt-get update on Ubuntu12.04, the error

Err http://packages.namniart.com precise Release.gpg
Could not resolve 'packages.namniart.com' Fetched 2,855 kB in 30s (94.9 kB/s)
Reading package lists... Done W: Failed to fetch http://packages.namniart.com/repos/ro... Could not resolve 'packages.namniart.com'

was given, while packages.namniart.com is reachable. Any idea ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-03-20 11:18:19 -0500

ahendrix gravatar image

It sounds like you have a network or DNS problem.

Can you ping packages.namniart.com from your board? If that doesn't work, can you ping www.google.com?

edit flag offensive delete link more

Comments

Yes, I can ping both from the board.

hvn gravatar image hvn  ( 2014-03-20 11:26:02 -0500 )edit

Try again and see if it was a fluke? Otherwise this sounds like it's an issue specific to apt.

ahendrix gravatar image ahendrix  ( 2014-03-20 11:45:16 -0500 )edit

I tried three times, both namniart and google. All pings work. Remarkable is that apt-get install start well and downloads the package, but stalls after that. Even kill -9 doesn't kill it. The failure of roscore (my original problem) has nothing to do with apt or Ubuntu, right ?

hvn gravatar image hvn  ( 2014-03-20 11:56:07 -0500 )edit

I suspect they're both symptoms of the same underlying problem. Perhaps the disk is full? Have you looked at the kernel logs at all?

ahendrix gravatar image ahendrix  ( 2014-03-20 12:15:27 -0500 )edit

Could be. Disk is at 57%, so no problem there. Kernel logs show nothing wrong so far. Will check further.

hvn gravatar image hvn  ( 2014-03-20 12:32:13 -0500 )edit

Reading this in the log: [xmlrpc][INFO] 2014-03-26 10:13:51,179: XML-RPC server binding to 0.0.0.0:0 [xmlrpc][INFO] 2014-03-26 10:13:51,182: Started XML-RPC server [http://BBxM:48536/] [xmlrpc][INFO] 2014-03-26 10:13:51,184: xml rpc node: starting XML-RPC server Is this correct ?

hvn gravatar image hvn  ( 2014-03-25 23:40:40 -0500 )edit

Does the hostname BBxM resolve on you machine? What IP address does it resolve to?

ahendrix gravatar image ahendrix  ( 2014-03-26 06:26:23 -0500 )edit

Yes it does. ping BBxM resolves to 127.0.1.1 which is set in /etc/hosts.

hvn gravatar image hvn  ( 2014-03-26 10:58:13 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-03-20 08:39:11 -0500

Seen: 380 times

Last updated: Mar 20 '14