winros_make fails [closed]

asked 2014-03-18 04:36:33 -0500

bnm-rc gravatar image

updated 2014-03-25 06:20:29 -0500

Hi,
I'm installing winros on a Windows 7 system according to this tutorial and am stuck at executing the winros_make command. It says

find_package(catkin) failed.  catkin was neither found in the workspace nor
in the CMAKE_PREFIX_PATH.  One reason may be that no ROS setup.sh was
sourced before.

I couldn't find any setup.sh file I could source. Can someone please help? Greets :)


EDIT 1
To satisfy Daniel Stoniers question in the commentaries here is my CMAKE_PREFIX_PATH from the generated configure.cmake file:

set(CMAKE_PREFIX_PATH "${CMAKE_PREFIX_PATH};${ROSDEPS_ROOT};${UNDERLAY_ROOTS}" CACHE PATH "semi-colon separated software/ros workspace paths.")

The referenced paths are defined as follows:

set(ROSDEPS_ROOT "C:/opt/rosdeps/groovy/x86" CACHE STRING "System root for ros dependency.")
set(UNDERLAY_ROOTS "" CACHE PATH "Semi-colon separated list of underlay roots.")

CLOSED
I closed this question, because the reason for the failure was a faulty system configuration. I installed the Windows SDK 7.1 parallel to my Visual Studio 2010, which caused the trouble. When I eventually retried on a clean system without installing the SDK, everything worked like a charm. Thanks very much though to everyone who helped me with this!

edit retag flag offensive reopen merge delete

Closed for the following reason question is off-topic or not relevant. Please see http://wiki.ros.org/Support for more details. by bnm-rc
close date 2014-03-25 06:16:53

Comments

have Your tried this command `call C:\work\ws\devel\setup.bat` before executing winros_make? That's an analogue for `source setup.sh` in Linux.

Kamiccolo gravatar imageKamiccolo ( 2014-03-18 07:39:39 -0500 )edit
1

Chicken and egg. He's running winros_make for the first time, which will create `setup.bat`. Note: you can ignore the reference to `setup.sh` here, it is a misleading reference at the end of the `toplevel.cmake` that is created. What does your `CMAKE_PREFIX_PATH in `config.cmake` look like?`

Daniel Stonier gravatar imageDaniel Stonier ( 2014-03-18 21:00:27 -0500 )edit

Hi, thanks for the comments. @Kamiccolo: as Daniel Stonier says, I'm running it for the first time, thus there is no devel directory yet. @Daniel Stonier: My `CMAKE_PREFIX_PATH` is defined by this line in the `configure.cmake`: `set(CMAKE_PREFIX_PATH "${CMAKE_PREFIX_PATH};${ROSDEPS_ROOT};${UNDERLAY_ROOTS}" CACHE PATH "semi-colon separated software/ros workspace paths.")`. ROSDEPS_ROOT is previously set by `set(ROSDEPS_ROOT "C:/opt/rosdeps/groovy/x86" CACHE STRING "System root for ros dependency.")` (I changed this line manually by replacing `hydro` through `groovy`) and UNDERLAY_ROOTS is set by `set(UNDERLAY_ROOTS "" CACHE PATH "Semi-colon separated list of underlay roots.")` (nothing changed here).

bnm-rc gravatar imagebnm-rc ( 2014-03-18 22:42:24 -0500 )edit

Check there is catkin package(c:/work/ws/src/catkin) first. According to instruction you followed, the word 'hydro' should not exist in 'config.cmake'. Is there any prior work about win_ros?

Yeongil Choe gravatar imageYeongil Choe ( 2014-03-19 14:06:22 -0500 )edit

@yichoe thanks for your comment. My src folder is empty except for two files .rosinstall and CMakeLists.txt . I don't think there has been prior work, and I installed only but all packages suggested in the mentioned tutorial. One thing that came to my mind: On http://wiki.ros.org/win_python_build_tools/groovy which is linked by the tutorial, there are listed some "example" commands for using the tools I should download there. Do I have to commit them or are they really just _examples_?

bnm-rc gravatar imagebnm-rc ( 2014-03-20 22:46:28 -0500 )edit

That is just examples for using wstool. Delete c:/work/ws, and try again from '2.2 Sources' section in the instruction. By the way how about starting with 'hydro' version not 'groovy'? Do you have any special reason to use 'groovy'?

Yeongil Choe gravatar imageYeongil Choe ( 2014-03-20 23:17:47 -0500 )edit

@Yeongil Choe thanks for your comment. I already tried that several times. I did it once again now and added the ouput of winros_make to my question. Yes, I need groovy. I am trying to connect an Ubuntu system with the winros_environment for monitoring reasons.

bnm-rc gravatar imagebnm-rc ( 2014-03-20 23:41:41 -0500 )edit

Ooookay.. I just reinstalled all the tools and rebootet, then set up a new workspace and called winros_init_workspace as written in the tutorial. I noticed tons of items being fetched from repositories which wasn't the case before. But still it doesn't want to compile. Seems my settings for the compiler are broken -.-

bnm-rc gravatar imagebnm-rc ( 2014-03-21 00:27:27 -0500 )edit