rosmake rgbdslam error

asked 2014-03-12 04:12:24 -0600

ap gravatar image

updated 2016-10-24 08:36:21 -0600

ngrennan gravatar image

Hi I am trying to install rgbdslam as per the link //wiki.ros.org/rgbdslam. When I run 'rosmake rgbdslam_freiburg'

I get the error below:

IOError: [Errno socket error] [Errno 1] _ssl.c:504: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol -------------------------}

[ rosmake ] Output from build of package octomap written to: [ rosmake ] /home/ap/.ros/rosmake/rosmake_output-20140312-152119/octomap/build_output.log [rosmake-11] Finished <<< octomap [FAIL] [ 0.37 seconds ]
[ rosmake ] Halting due to failure in package octomap. [ rosmake ] Waiting for other threads to complete. [ rosmake ] Results:
[ rosmake ] Built 43 packages with 1 failures.
[ rosmake ] Summary output to directory
[ rosmake ] /home/ap/.ros/rosmake/rosmake_output-20140312-152119

I tried deleting the octomap_msgs and octomap_mapping packages and installing them again and running the 'rosmake rgbdslam_freiburg' but I get the same error above. I also tried making the packages before I run the 'rosmake rgbdslam_freiburg' command. The packages compile with no errors but I still get the error above when I run the mentioned command.

I'm using Ubuntu 12.04 LTS and ROS Fuerte. Help would be much appreciated. Thank you

edit retag flag offensive close merge delete