ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Error in Arduino-ROS connection

asked 2014-03-11 00:56:53 -0500

Jota gravatar image

updated 2014-03-11 22:05:57 -0500

Hello to all!

A few months ago, I connected Arduino to ROS fuerte using rosserial without problems. However, now I'm trying to reproduce it in ROS groovy and I always get the same error.

I am working with Ubuntu 12.04, ROS Groovy, Arduino 1.0.5, rosserial-groovy-devel and both Arduino Uno and Arduino Mega.

I do these commands:

Window 1:

sudo ./Arduino/arduino

Open Hello World example.

Select Controller Arduino Uno/Mega.

Select Serial Port /dev/ttyACM0.

Load code.

Window 2:


Window 3:

sudo chmod a+rw /dev/ttyACM0

rosrun rosserial_python /dev/ttyACM0

And I get this error:

[INFO] [WallTime: 1394533587.406466] ROS Serial Python Node

[INFO] [WallTime: 1394533587.419060] Connecting to /dev/ttyACM0 at 57600 baud

[ERROR] [WallTime: 1394533590.332723] Creation of publisher failed: unpack requires a string argument of length 4

[ERROR] [WallTime: 1394533591.328157] Tried to publish before configured, topic id 125

Anyone can help me?

Thanks in advance!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2014-03-11 17:33:51 -0500

updated 2014-03-11 17:33:59 -0500

Try removing and remaking your ros_lib.

edit flag offensive delete link more

answered 2014-03-11 23:24:40 -0500

Jota gravatar image


There was a problem in the installation of ros_lib due to Arduino sketchbook permissions.


edit flag offensive delete link more

Question Tools



Asked: 2014-03-11 00:56:53 -0500

Seen: 519 times

Last updated: Mar 11 '14