ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Talk to Your Robot

asked 2012-02-08 06:46:33 -0500

gray8118 gravatar image

I have been using the tutorial files for making a turtlebot move under voice command. I have worked through all the tutorials and actually see the commands “ forward, rotate left. Etc “ display on the screen. Using the turtlebot dashboard diagnostic screen I can see the command words being posted via rospy.loginfo(). However, the TWIST commands do not seem to be Processing or possible not being posted to the bot. I switched over to use the teleop_keyboard and all works well.

It seems as if something is not turned on or I am missing something. I am running ROS Electric on both the bot and workstation.

I have used rostopoic echo /cmd_vel and see no output data

Using rostopic echo /turtlebot_node/cmd_vel I can see linerar and angular data being displayed. After issueing several commands you can see the linear data increase and decrease and angular data when commanding the bot to turn or rotate. The bot never moves.

Any suggestions or comments would be greatly appreciated?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted

answered 2012-02-08 11:32:28 -0500

Pi Robot gravatar image

Looks like I was still remapping cmd_vel to turtlebot_node/cmd_vel in the turtlebot_voice_nav.launch file as used to be necessary in Diamondback but no longer in Electric. The latest SVN version has been fixed so you could do an "svn update" in the pi_speech_tutorial directory. Alternatively, simply delete the following line from the turtlebot_voice_nav.launch file:

<remap from="cmd_vel" to="/turtlebot_node/cmd_vel"/>

Please let us know if that fixes the problem. (You can check this answer as accepted if it does.)


edit flag offensive delete link more


Works great now Patrick. Thanks for your quick response. Looking forward to building upon this experience.
gray8118 gravatar image gray8118  ( 2012-02-09 02:48:21 -0500 )edit

answered 2012-02-08 18:30:41 -0500

Gemini Ma gravatar image

I had the same problem before. Now it works. Thanks, Patrick!

edit flag offensive delete link more

Question Tools


Asked: 2012-02-08 06:46:33 -0500

Seen: 465 times

Last updated: Feb 08 '12