Ask Your Question
0

installation problem in ROS

asked 2012-02-06 16:36:07 -0500

nandhini gravatar image

i tried to install ros in ubuntu 10.04 lucid but when i gave command i got following error:

sudo apt-get install ros-electric-desktop-full

Reading package lists... Done Building dependency tree       Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: ros-electric-desktop-full: Depends: ros-electric-slam-gmapping (= 1.2.5-s1326424166~lucid) but it is not going to be installed Depends: ros-electric-perception-pcl (= 1.0.2-s1323553637~lucid) but it is not going to be installed Depends: ros-electric-simulator-gazebo (= 1.4.10-s1326937730~lucid) but it is not going to be installed Depends: ros-electric-navigation (= 1.6.5-s1323562415~lucid) but it is not going to be installed E: Broken packages

what should I do?

When I tried to install from the source for the setup command :

“sudo apt-get install build-essential python-yaml cmake subversion wget python-setuptools mercurial git-core”

I got the following error:

Errors were encountered while processing:

/var/cache/apt/archives/xz-utils_4.999.9beta+20091116-1_i386.deb

/var/cache/apt/archives/patch_2.6-2ubuntu1_i386.deb

/var/cache/apt/archives/dpkg-dev_1.15.5.6ubuntu4.5_all.deb

/var/cache/apt/archives/build-essential_11.4build1_i386.deb

/var/cache/apt/archives/dkms_2.1.1.2-2ubuntu1_all.deb

/var/cache/apt/archives/fakeroot_1.14.4-1ubuntu1_i386.deb

/var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu5_i386.deb

/var/cache/apt/archives/fglrx-amdcccle_2%3a8.723.1-0ubuntu5_i386.deb

/var/cache/apt/archives/libboost1.42-dev_1.42.0-3~lucid1_i386.deb

/var/cache/apt/archives/libboost-dev_1.42.0.1~lucid1_i386.deb

/var/cache/apt/archives/libboost-serialization1.42-dev_1.42.0-3~lucid1_i386.deb

/var/cache/apt/archives/libboost-date-time1.42-dev_1.42.0-3~lucid1_i386.deb

/var/cache/apt/archives/libboost-date-time-dev_1.42.0.1~lucid1_i386.deb

/var/cache/apt/archives/libboost-system1.42-dev_1.42.0-3~lucid1_i386.deb

/var/cache/apt/archives/libboost-filesystem1.4E: Sub-process /usr/bin/dpkg returned an error code (1)

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
1

answered 2012-02-08 14:18:52 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Based on your own answer and the fact that you cannot install the prerequisites you appear to have conflicts in your PPA sources which conflict with standard Ubuntu packages. You'll have to resolve that before continuing.

edit flag offensive delete link more

Comments

can u say how to resolve it?
nandhini gravatar image nandhini  ( 2012-02-09 15:15:20 -0500 )edit
0

answered 2012-02-06 19:00:30 -0500

nandhini gravatar image

when i give sudo apt-get install any package i get 15 upgraded, 1 newly installed 0 to remove and 0 not upgraded 51 not fully installed or removed

when i tried to install libboost bcp package from ppa ubuntu for lucidi386 i got

Error:breaks existing package 'libboost1.42-dev'conflict:bcp()

edit flag offensive delete link more

Comments

Please use the edit button to update your post with new information.
tfoote gravatar image tfoote  ( 2012-02-08 14:17:15 -0500 )edit
0

answered 2012-02-06 16:45:30 -0500

Micke gravatar image

Have had a similar problem and found out that I had to reinstall boost..

edit flag offensive delete link more
0

answered 2012-02-07 01:03:24 -0500

osuairt gravatar image

Have you tried sudo apt-get install -f?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-02-06 16:36:07 -0500

Seen: 476 times

Last updated: Feb 08 '12