Ask Your Question
1

pip/easy_install -U rosinstall problem

asked 2012-02-01 18:47:03 -0500

prince gravatar image

updated 2012-03-13 22:12:18 -0500

Hi, I am installing Diamondback afresh on Ubuntu10.04 using repository deb packages. The steps are followed as given in wiki. By default rosinstall is not setup. I am stuck while following the steps as in http://ros.org/wiki/rosinstall . I am behind a proxy for which http_proxy and https_proxy is defined.

Following is the output on console:

Searching for rosinstall

Reading http://pypi.python.org/simple/rosinstall/

Download error: [Errno -2] Name or service not known -- Some packages may not be found!

This repeats couple of times. Is this issue related to proxy??? I do not face any problem when having a direct internet connnection.

Also installation of package ros-diamondback-ros-release deb ver:0.1.14-s131s503298 do not help.

I had also tried using pip. Following is the output of pip log.

  Downloading/unpacking rosinstall
  Getting page http://pypi.python.org/simple/rosinstall
  Could not fetch URL http://pypi.python.org/simple/rosinstall: <urlopen error [Errno -2] Name or service not known>
  Will skip URL http://pypi.python.org/simple/rosinstall when looking for download links for rosinstall
  Getting page http://pypi.python.org/simple/
  Could not fetch URL http://pypi.python.org/simple/: <urlopen error [Errno -2] Name or service not known>
  Will skip URL http://pypi.python.org/simple/ when looking for download links for rosinstall
  Cannot fetch index base URL http://pypi.python.org/simple/
Cannot find requirement rosinstall, nor fetch index URL http://pypi.python.org/simple/
Exception information:
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/pip.py", line 252, in main
    self.run(options, args)
  File "/usr/lib/python2.6/dist-packages/pip.py", line 408, in run
    requirement_set.install_files(finder, force_root_egg_info=self.bundle)
  File "/usr/lib/python2.6/dist-packages/pip.py", line 1750, in install_files
    url = finder.find_requirement(req_to_install, upgrade=self.upgrade)
  File "/usr/lib/python2.6/dist-packages/pip.py", line 996, in find_requirement
    url_name = self._find_url_name(Link(self.index_urls[0]), url_name, req)
  File "/usr/lib/python2.6/dist-packages/pip.py", line 1073, in _find_url_name
    raise DistributionNotFound('Cannot find requirement %s, nor fetch index URL %s' % (req, index_url))
DistributionNotFound: Cannot find requirement rosinstall, nor fetch index URL http://pypi.python.org/simple/

Thanks prince

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2012-02-22 15:31:40 -0500

tfoote gravatar image

It looks like easy_install obey's a environment variable to setup proxys. blog post

You can also use pip the replacement for easy_install which has a --proxy argument man page

edit flag offensive delete link more

Comments

I did set http_proxy, https_proxy. It did not worked and I end up copying packages from other machine. Maybe something is broken here or i might had made some silly mistake in exporting http_proxy. I believe we shall close this question.

prince gravatar image prince  ( 2012-02-22 18:19:30 -0500 )edit

It still do not works :( I can go to webpage http://pypi.python.org/simple/rosinstall/ and download one of rosinstall pkgs. What next shall i do? Readme file is not helpful enough.

prince gravatar image prince  ( 2012-02-29 21:52:55 -0500 )edit

This is a problem for pip/easy_install community. I suggest that you ask this problem on their forums.

tfoote gravatar image tfoote  ( 2012-03-01 10:17:40 -0500 )edit
0

answered 2012-10-29 03:31:06 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I had similar issue with proxy environment

Here is how I solved the issue: 1. Setup the proxy in /etc/environment file 2. use "sudo -E easy_install <command>"

-E option used the environment of the current user.

Let me know if this helps you to solve the issue

edit flag offensive delete link more
0

answered 2012-03-10 21:26:44 -0500

KruseT gravatar image

updated 2012-03-14 08:15:29 -0500

Also please avoid $ easy_install -U rosinstall

I changed that on the wiki page as well. Use

$ sudo easy_install -U rosinstall vcstools

or

$ sudo pip install -U rosinstall

edit flag offensive delete link more

Comments

i had attached pip command log with main question.

prince gravatar image prince  ( 2012-03-13 22:12:55 -0500 )edit

sure i just responded to the title of you question. It was just a remark.

KruseT gravatar image KruseT  ( 2012-03-14 08:16:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-02-01 18:47:03 -0500

Seen: 3,041 times

Last updated: Oct 29 '12