Ask Your Question
0

Problem installing openni_kinect

asked 2012-01-13 09:53:48 -0500

famlyguy1989 gravatar image

I started using ROS last week and tried installing openni_kinect. I followed the steps here:

http://www.ros.org/wiki/openni_kinect

Everything seems to work properly until I get to step 4 when I start to compile. I get an error:

[ 20%] Building CXX object CMakeFiles/depth_image_proc.dir/src/nodelets/register.o /home/drcool/openni_kinect/openni_kinect/depth_image_proc/src/nodelets/register.cpp: In member function ‘void depth_image_proc::RegisterNodelet::imageCb(const ImageConstPtr&, const CameraInfoConstPtr&, const CameraInfoConstPtr&)’:

/home/drcool/openni_kinect/openni_kinect/depth_image_proc/src/nodelets/register.cpp:117:5: error: ‘Matrix3x3’ is not a member of ‘tf’ /home/drcool/openni_kinect/openni_kinect/depth_image_proc/src/nodelets/register.cpp:117:20: error: ‘R’ was not declared in this scope

make[3]: [CMakeFiles/depth_image_proc.dir/src/nodelets/register.o] Error 1 make[3]: Leaving directory /home/drcool/openni_kinect/openni_kinect/depth_image_proc/build' make[2]: *** [CMakeFiles/depth_image_proc.dir/all] Error 2 make[2]: Leaving directory/home/drcool/openni_kinect/openni_kinect/depth_image_proc/build' make[1]: *[all] Error 2 make[1]: Leaving directory `/home/drcool/openni_kinect/openni_kinect/depth_image_proc/build'*

The bolded section states the specific error. Before I began installing this I installed the nao stacks for ROS located here:

http://www.ros.org/wiki/nao/Installation

My current system is Ubuntu 11.10 oneiric, and I did a full desktop install of ROS electric. Any help with this problem would be appreciated.

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
5

answered 2012-01-13 10:45:30 -0500

ahendrix gravatar image

If you're using ROS on Ubuntu, you shouldn't have to install the drivers from source; just do:

sudo apt-get install ros-electric-openni-kinect

edit flag offensive delete link more
0

answered 2012-01-29 16:37:25 -0500

I have this exact error, I haven't been able to fix it yet. I think it has to do with the particular version of Eigen used in the geometry stack, but I'm not sure. If you find an answer please update. Thanks.

edit flag offensive delete link more
0

answered 2012-01-31 12:31:22 -0500

Patrick Mihelich gravatar image

As mentioned above, since you're on Ubuntu just follow the "Ubuntu installation" instructions to install the prebuilt packages.

I corrected the openni_kinect.rosinstall file linked through the wiki to install the electric tag of openni_kinect instead of default (where active development happens), so the source installation instructions should work again. Your errors resulted from building the Fuerte version of openni_kinect against Electric.

edit flag offensive delete link more
0

answered 2012-01-31 06:06:54 -0500

Ramya gravatar image

I have the same error can you help me out from this error

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-01-13 09:53:48 -0500

Seen: 593 times

Last updated: Mar 07 '12