Ask Your Question
2

ROS connectivity and usernames

asked 2012-01-11 20:29:21 -0500

Ibrahim gravatar image

I think I've just discovered a really dumb mistake on my part and I want confirmation as to whether this matters. On two machines (one of which is the ROS_MASTER, c1), my username is ibrahim, but on some other machines that are connected to the ROS_MASTER through openvpn on the PR2 basestation, my username is ibrahima. On the machines with username ibrahima I can read topics fine, but I can't access services. Does ROS assume that you can ssh with the same username into other machines? I have set up an ssh config file (~/.ssh/config) such that I can ssh without having to type the proper username but I still can't get services to work. For example, if i run rosservice call static_map where static_map is running on the basestation, it says it's Unable to communicate with service /static_map. I've set ROS_IP on the other machines to be the VPN IP address and not the WAN IP, which fixed things like running rosnode info on a node running on a VPN-connected machine but this doesn't seem to help with services.

Is it just the username being an issue, or are there more steps needed to set up VPN connected computers besides setting up the connection and setting the proper ROS_MASTER_URI, ROS_IP, and any necessary entries in /etc/hosts

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2012-03-05 11:27:20 -0500

tfoote gravatar image

ROS communications do not require username or authentification. Read the technical overview

The only thing which requires SSH username and keys is roslaunch. All other communications simply require port numbers.

There appears to be an issue with something like routing or name lookup and services. If you can describe how to reproduce it we can take a closer look.

edit flag offensive delete link more

Comments

1

Agreed; this is probably a problem with name resolution on your network. Running 'rosservice info <service>' should show you which hostname clients are using when creating service clients. You should make sure that this name resolves properly on all machines.

ahendrix gravatar imageahendrix ( 2012-03-05 16:03:49 -0500 )edit

It was probably a routing issue, I actually am not sure at the moment if the issue still exists because I'm not in the lab at the moment but I think somehow I figured it out or it magically fixed itself.

Ibrahim gravatar imageIbrahim ( 2012-03-06 09:56:54 -0500 )edit
0

answered 2012-01-12 00:50:58 -0500

DimitriProsser gravatar image

There is this outstanding question regarding services on multiple machines that has yet to be resolved.

edit flag offensive delete link more

Comments

Yup, that's similar to the problem I'm having (perhaps the same) but it seems like you weren't able to get your problem resolved :(
Ibrahim gravatar imageIbrahim ( 2012-01-12 12:25:43 -0500 )edit
That is correct. Still no luck.
DimitriProsser gravatar imageDimitriProsser ( 2012-01-13 01:00:15 -0500 )edit
0

answered 2012-01-11 21:14:17 -0500

dornhege gravatar image

For all I know communication between ROS nodes is independent of user names (it doesn't use SSH anyways).

Check this page for other problems: http://www.ros.org/wiki/ROS/NetworkSetup

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-01-11 20:29:21 -0500

Seen: 1,413 times

Last updated: Mar 05 '12