Ask Your Question
0

Tutorial: Understanding a Topic: run rxgraph I got a nameError

asked 2011-12-28 12:58:47 -0500

Hi all, I am following the ROS tutorial and now come to the Understanding ROS Topics. When I key in rxgraph, it give me

Traceback (most recent call last): File "/home/btian/ros/ros/bin/rxgraph", line 36, in <module> rxgraph.rxgraph_main() File "/home/btian/ros/rx/rxgraph/src/rxgraph/__init__.py", line 61, in rxgraph_main print >> sys.stderr, "Graphviz does not appear to be installed on your system. Please run:\n\n\trosdep install rosgraph\n\nto install the necessary dependencies on your system" NameError: global name 'sys' is not defined

But \n\n\trosdep does not exist. I tried import sys also, does not help. any idea how to get over this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2011-12-28 13:05:21 -0500

I installed graphvis in synaptic ...

Done. it works now.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-12-28 12:58:47 -0500

Seen: 412 times

Last updated: Dec 28 '11